I'm trying to play music through Ventrilo and currently I use Virtual Audio Cable. The way it works is that in foobar2000 (a music playing program) I set the output device in preferences to Virtual Audio Cable. Then in Ventrilo I log in to another name and set the input device to Virtual Audio Cable. This routes the music through the Virtual Audio Cable and allows me to play the music through Ventrilo.

However, I would also like to change the output device for Firefox (or any other browser) or "Plugin Container for Firefix" to Virtual Audio Cable so that I could play music from Pandora or YouTube on to Ventrilo. Unfortunately I could not find an option for this anywhere.


7 Answers 7


One thing you can do since I had the same issue is set your OS to use a virtual cable as the default device.

Adobe Flash uses windows defaut and in doing this you will have set firefox to use the VAC for flash based objects (I have verified that flash is sending the audio not firefox for flash based objects or movies)

Then simply use a repeater to send that VAC to your original sound device (soundcard) so you will hear everything like normal but have a VAC tied in the middle that you can work with to do other things.

Ultimately, what worked best for me was to just use a secondary device and send it to my computer with a line-in (use my hp touchpad) this let me drop the huge net of VAC and Repeaters that was causing a delay in my recordings and also let me control that external audio source while in game easily since its on a separate device.


Software solution for this: https://github.com/audiorouterdev/audio-router

You can choose output for each app.

  • 2
    Please read How do I recommend software for some tips as to how you should go about recommending software. You should provide at least a link, some additional information about the software itself, and how it can be used to solve the problem in the question.
    – DavidPostill
    Feb 26, 2017 at 17:51

Found your answer:

Use virtual audio cable (search it) to create a new virtual audio line. Once line 1 is working, go to sound in the control panel and change the default sound device to line 1. Open 2 vent applications. For the one you want to play music thru change the input to line 1 and the output to speakers. Outside setup check the mute sound option at the bottom of the vent window. (Having sound on will cause lots of echo.)

For your other user select input to be headset. And output to be stereo mix or speakers. This way you and all others will be able to hear the music over vent and you can still speak without echos. Open firefox last so it binds to the default device (line 1). And enjoy.

(NOTE: You will not be able to hear sound from firefox without being in vent where it is coming from. To change it back just go to sound and select speakers as the default device again.

Hope this helps.

  • Anon Commented: You can select "Line 1" and enter its properties, checking "Listen to Device." Then, he doesn't need to be in the same channel or even have the "user" playing to his ears. However, I don't use the same VAC as you do. I don't have "Lines." Regardless, I do this in TeamSpeak. Perfectly fine.
    – Psycogeek
    Oct 8, 2015 at 9:51

On Ubuntu Mate 20.04 I had the same problem with Firefox after doing some reading I installed pavucontrol from the snap.
Without making any changes it seems to have fixed my problem.


You're doing it wrong. Typically, applications use the OS-provided libraries to output sound. Thus, the settings should be located... you guessed it, in the OS sound configuration. I forget exactly where it is in Windows 7, but if you search for "sound" in the start search, it should be easy enough to find.

  • I couldn't find it. I'm not trying to change my default playback device. I still want to be able to hear incoming sound with my headset and that's why Virtual Audio Cable is so nice. May 5, 2011 at 1:16
  • 2
    Wrong, output device can and should be an application function. Many applications will use only the default Windows sound device, much to the frustration of many users, Flash Player being one of the major ones. This makes the solution you propose still the only option, but what other choice do you have eh?
    – user120198
    Feb 26, 2012 at 18:33
  • 2
    The answer from Hello71 isn't correct. There are many cases where you might want the audio from one application to go to a different device than other applications. Doing this from the OS is not possible - it has to be done from within the application.
    – user123289
    Mar 16, 2012 at 11:52
  • @Anon: This is hypothetically possible from the OS; however, most OSes simply implement an audio sink because separate audio devices are an edge case.
    – Hello71
    Mar 17, 2012 at 1:02

Output device selection is an application function. Firefox doesn't actually do any audio output, so it doesn't have a setting. The software actually responsible for selecting an output device and playing audio is the plugin, Adobe Flash Player in most cases.

Unfortunately, Adobe has not yet seen fit to create a way to configure Flash Player to use a specific output device. It always uses the system default.

As a potential workaround, you might be able to configure everything else to use what should be the default, then change the default to the alternate... But that's terribly cumbersome.

  • 5
    This wasn't entirely true when you answerd this and certainly isn't now. Firefox has supported HTML5 audio since at least Q1 2011 and it is enabled by default now.
    – cb88
    May 17, 2015 at 13:23

Jason Sherman afforded a very comprehensive overview of this functionality. I appreciate. But as a workaround, you could redirect whole audio output toward speakers (while headphones plugged in) in Windows 10. You can do the trick by right-clicking on speaker icon in system tray. Choose Playback device. Press 'Set Default' button after clicking on speakers. Voila! Your audio is in the speakers with headphones plugged in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.