4

I've got Ubuntu 11.04, but I'm trying to go back to windows 7. I know this is supposed to be easy, but I've tried every method I can think to no avail. I've burned at least 6 Windows 7 disks that did not work, tried multiple ISO files (assuming that some were corrupt in some way) on both dvds and usb devices, and consistently get the same error. What happens is when I restart and boot from the usb/cd/dvd drive, windows begins to setup, but before it can start to install, I get an error saying that a cd/dvd/media driver is missing. It then gives me the option to insert a media that has the driver to install it. I read dozens of threads, and finally read from someone who had the same problem, and found that it wound up being because of his SATA drivers, but I have been unable to to navigate Ubuntu well enough to know if this is true, or where to get SATA drivers. Any ideas/fixes I should try?

edit: I am trying to replace Ubuntu, not dual boot both OS's together.

5
  • 1
    Question makes no sense. You said you are trying to install Windows 7 and it complains about lack of a driver. This has nothing to do with Ubuntu. If this is a typo and you meant Ubuntu, then you need to give the EXACT error message and/or post a screen shot. – psusi May 4 '11 at 23:16
  • No, I meant Windows 7. I already downloaded the SATA driver that was recommended for my laptop and put it on a usb device. When the driver error came up again, I prompted usb device containing the driver for download. The other forum said I would have to uncheck a box that hides incompatible drivers, so I did. But the driver was not detected. I thought this would be an Ubuntu issue because that SATA driver was recommended for Windows 7 64bit, but I am running Ubuntu, so it naturally did not work. – Anonymous May 4 '11 at 23:28
  • I edited the title to make it match the question. I suggest you add some details of the hardware and the source of your Windows-7 installation media (or ISO files). – RedGrittyBrick May 5 '11 at 9:42
  • Consider posting the make and exact model of the PC. – Moab May 5 '11 at 15:27
  • I had the same problem with a windows 10 install - my fix below. – Dan Pritts Apr 13 '20 at 15:11
13

Your problem has nothing to do with Ubuntu. I had the same problem when installing windows 7 onto a SATA HDD with USB. Some possible solutions I have found includes

  • If you are installing with CD, burn ISO with the slowest speed
  • If you are installing with USB drive, when it asks for driver, click Cancel. Once you are at the welcome screen, insert the USB drive to a different USB port. Then click Install Now to install.

You may also first try installing the ISO you have on a virtual machine, just to make sure it is not corrupted.

5
  • agreed, ubuntu doesn't change crap in windows, it doesn't just modify registries, etc. – alexmherrmann May 18 '12 at 18:25
  • 4
    This post deserved MUCH credits. According to this post, more than 280 people have accepted this answer. Really nicely figured out =-D answers.microsoft.com/en-us/windows/forum/… – mraxus Aug 29 '17 at 20:01
  • 1
    I had the same problem with a windows 10 installation. This worked for me. – M6299 May 4 '18 at 5:24
  • Tried all my USB ports, none working :( – Dan J Nov 12 '18 at 22:37
  • I had the same problem, tried different ports, tried to reboot PC, again changing ports etc. and eventually it worked. Windows 10 version 1803. Thanks! – Micer Jan 28 '20 at 21:45
5

Probably trying to install from a USB 3.0/3.1 port. Windows doesn't usually have the drivers for those. Try installing it from a normal USB port

2
  • Using a usb3 stick on a usb 2 hub worked for me. I feel really stupid tough. – Gellweiler Jul 9 '20 at 12:10
  • Even this did not work, I had to dig up an old USB 2 flash drive instead of my USB 3 drive – user5359531 Mar 25 at 20:32
3

I was having this same problem trying to install a Windows 10 ISO with any of several USB drives (16 and 32GB) on a Surface Pro 4 (which unfortunately has only one USB port, a USB 3 one, ruling out @wei-shi's answer).

The solution in my case was rather than copying the ISO straight to the drive, instead to create a 5GB FAT32 partition on there, mark it bootable, then copy the files from the ISO into that. This booted perfectly and the installer finally made it to the next screen.

On Linux this can be done roughly as follows:

sudo fdisk -l    # to figure out which connected drive is which

sudo fdisk /dev/sdb    # assuming "/dev/sdb" is the USB drive
    # You're now using fdisk, which has its own interactive interface.
    # It will create a partition on the USB drive for you to use as a FAT32 filesystem.
    # Type the following single-letter commands to go through the process:
    (m for help)

    o to clear out the partition table for a new empty one
    n for new partition
        (follow steps, [enter] for default position, size "+5G")
    l for see possible types
    t for set type
        (probably "b" for Win95 FAT32)
    a for mark as bootable
    w to write the partition table to the drive and quit
    q if it does not quit automatically after w

# Now you should be back in your normal command shell with a prompt like "$" rather than "Command (m for help):"

# Format the newly-created partition with a Windows FAT32 filesystem
sudo mkfs.fat -F 32 /dev/sdb1

# Create directories, and mount the ISO and the FAT32 filesystem to them
sudo mkdir /mnt/usb /mnt/iso
sudo mount /dev/sdb1 /mnt/usb
sudo mount -o loop ~/path/to/windows.iso /mnt/iso

# Copy the installer files to the USB drive
cp -r /mnt/iso/* /mnt/usb    # now wait...

# Eject the drive (and the ISO)
sudo umount /mnt/usb /mnt/iso    # and wait some more...

# It's safe to unplug the drive when the `umount` command finishes.

There are probably easier tools to do this or ways to achieve it from a Windows installation, but it's hard to know exactly what they'll do whereas this is nice and simple, in that way at least. All I know is when I tried this method on a whim it worked.

Good luck!

5
  • This whole chain of commands... Did exactly nothing. This is the output for me: i.imgur.com/sxCT9z3r.jpg – Xerus Mar 16 '18 at 18:16
  • The unindented commands are for the normal shell. While in fdisk, it has its own shell-like interactive interface (prompt "Befehl:"). The indented commands (single letters) are a sequence of instructions -- o, n, l, t, a and w -- which you need to enter to tell fdisk to format the disk. Then, when you've finished and left fdisk, the rest of the commands will work in the normal shell (prompt ending with ~ $ which you saw before fdisk). – Tom Spurling Mar 20 '18 at 17:17
  • 1
    Should be cp -r – Jon Deaton Jan 4 '20 at 22:37
  • 1
    The file sources/install.wim is too big for FAT32 – Codebling Oct 26 '20 at 0:32
  • In our case, the Windows 10 ISO contained a file > 2GB, and thus too large for FAT32. Fortunately, GRUB can understand NTFS. So we formatted the partition as NTFS (via Gnome Disks GUI), noted down the partition‘s UUID and unpacked the ISO to the partition (via Nautilus). Then, we used following GRUB commands: insmod ntfs // insmod part_gpt // insmod chain // insmod search_fs_uuid // search --fs-uuid --no-floppy --set=root your_install_partition_uuid // chainloader /efi/boot/bootx64.efi // boot . YMMV – ominug Nov 26 '20 at 9:05
1

A little late to the party, but my solution was move my USB 3 flash from a USB 3 port to a USB 2 port. I was trying to load from a USB 3 port and it failed every time. I moved my flash drive to a USB 2 port and it booted and loaded correctly.

1

Similar to @Tom Spurling, my problem was:

  • bought win10 academic edition through university, took me to special academic download page
  • that page had iso's only (because i was using a mac), and no mention of how to make a usb
  • i followed (wrong) instructions I found elsewhere online about making a USB from the ISO

My solution was to hit the download page from a windows machine. That gave me a link to download the windows USB Installer Maker tool. Using that I was able to make a working USB installer. It's irritating that I had to go this direction but it was a lot simpler to find the windows machine than it was to figure out what was missing from my self-made USB.

0

If you are "going back to Windows-7" this implies that the computer was originally supplied with Windows-7. In that case you should ignore Ubuntu and use the Windows-7 installation CD/DVD or the Windows-7 recovery CD/DVD that was supplied with the computer. If you do not have such a CD/DVD you should ask the retailer for one or contact the computer manufacturer for support. The manuals supplied with the computer should explain how to reinstall Windows-7.

I thought this would be an Ubuntu issue because that SATA driver was recommended for Windows 7 64bit, but I am running Ubuntu, so it naturally did not work.

When you boot the Windows-7 installation CD/DVD you are not running Ubuntu. The presence of bootable Ubuntu files on your hard disk (HDD) has no relevance, because your computer boots from CD/DVD not from HDD.

0

With Windows 10 I had the same issue installing from USB. Remove stick and plug into different USB port. X out of the installation so it brings you back to the install/repair screen and try again. It moved through without issue for me.

1
  • How does your answer differ from @wei-shi 's? – alljamin Oct 25 '16 at 8:40
0

Well I tried several times to boot to my acer spin1,to no avail! Read a post by linuxbabe,she says to format usb to a gpt partition then format it again with fat 32,note gparted does format my 64 gig usb drive all the way!no problem!so I partitioned it with a 7 gig fat32 partition and labeled it"boot/efi"!then I formated the remainder of the drive as fat 32 . I copied the extracted window10 from a debian buster desktop to the first portion of this drive,then after downloading acer spin 1 113 drivers ,I copied them to the remaining portion of the drive. I also copied the acer drivers to another usb 64 gig formatted as fat32,with the acer drivers. Inserted this into my drive,I had set the bios to bios mode before but set it to uefi,and disabled safe boot. This time I got the windows installer to boot,but it asks for a media driver. Others have suggested removing the drive when it asks for this and put it in another usb drive. I tried,no good! I did have a wifi driver ,and windows did try to go online, which would have made it a whole lot better. There is a small line at the bottom of the install page that says repair your system"click on that gets you to the repair page. Got any suggestions on how to get past this stop block? Also you can get into a page by going to c drive or by typing notepads in c:,for some reason debian gets bogged down trying to copy the boot wim or install wim,these are the major system files and you need them.If you can't get a boot screen when you try to boot your os off of usb,unmount it on a linux desktop,and reformat it again and copy windiws10 again to your usb. Getting past the initial boot stage is the problem! David

4
  • Update re:windows10 install,I found a link called:"linuxbabe.com",she has a link to an older version of windows 10 may 2018! If you want to get windows on your acer spin1 laptop or desktop,download a copy of this,It works,no run run around,no searching for medi drivers, no swapping from one usb to another!it just works without the bs!. – david russell May 9 at 22:25
  • I'm happy now!got my windoz back,and for all you people that say download it and use a format tool that is. exe,don't forget,when you have no windows,you have no Wifi!So don't forget that when you tell us to just download it!can't use Rufus in linux!!!but can extract windows 10 in linux to a usb,after its formatted with gpt and fat32! – david russell May 9 at 22:28
  • There's some things windows does better than linux,I have to admit,apparently according to linuxbabe.com ,banking online is one of them!as she says her bank doesn't do linux, but I bet there servers are running linux!,or maybe windows server?there are certain programs windows does better than Linux! – david russell May 9 at 22:43
  • I deleted my post you have to have points to post here, ,but apparently the server just pinked it out ,not deleted it!touche' – david russell May 12 at 5:32