I'm running Synergy 1.4.2 on two desktops: a server running Win7, and a client dual-booting Vista and Ubuntu 11.04. Synergy runs fine when the client boots to Vista, but when it boots to Ubuntu, Synergy won't connect the client to the server.

I've changed the Ubuntu box's hostname so that it's the same as the hostname under Vista; that way, the Synergy server configuration should work no matter which OS the client boots. I've also created inbound and outbound exceptions to the Win7 firewall for all 3 executables, (qynergy, synergys, and synergyc) -- overkill, probably, but I'm at a loss. I get the same error over and over:

connecting to 'Server': xxx.xxx.xxx.xxx:24800
failed to connect to server: Timed out.

I'm stumped. Something is keeping the client box from seeing the server box, but I can't figure out what. I'm an Ubuntu noob, so it wouldn't surprise me if there were some setting I'm unaware of.


  • Nevermind -- I substituted the server's IP address in place of its hostname and it worked perfectly. – screamline May 5 '11 at 6:38
  • I've crafted an answer from your comment so the question can be answered and put to bed. – Majenko May 5 '11 at 9:13

Check that the IP address that is being connected to is the correct one for the server.

If not, try connecting with the specific IP address. It could be a name resolution error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.