Possible Duplicate:
EXE file package repair

I'm trying to download the Oracle VM with Enterprise Linux and database tools from here.

It's an appliance that can be imported with VirtualBox and then run.

It requires 3 files - I've downloaded 2 files and checked the hash with an utility called FastSum. They're correct.

But I've downloaded the third file 3 times - each time the hash is different than those specified on the Oracle website. I've used Orbit and then IDM.

I've a very bad Internet connection - to download the 1.3 GB file it took me 8 hours.

So is there a download manager that download the file correctly (with hash check)?
Or how can I solve this ?

marked as duplicate by random Jun 4 '11 at 11:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which OS? Which browser? – boehj May 6 '11 at 16:50
  • Windows and i've used IDM to download , not via browser... – vettipayyan May 6 '11 at 16:52
  • If they're not offering a .torrent for a file this big, that's highly unreasonable of them. A similar situation for OS X users that want to download their Update Combo (>1 GB). It's basically click 'download' and hope for the best. – boehj May 6 '11 at 16:55

Take a look at this similar (identical?) question and my answer to it.

  • i've asked for torrent file in Oracle forum , no one replied . It seems only direct downloading . Also i'm a regular user of wget , but oracle uses authentication during downloading . i tried the same url with wget , but it failed :( – vettipayyan May 6 '11 at 16:46
  • Which kind of authentication? You can pass cookies with curl to get around authentication. – slhck May 6 '11 at 17:31
  • i tried using this method by a guy from otn : forums.oracle.com/forums/thread.jspa?messageID=2666987 Failed – vettipayyan May 6 '11 at 17:47
  • Somewhere i read , that the download manager - GetRight hash checks its files . But their website mentions nothing . Has anybody used GetRight ? – vettipayyan May 6 '11 at 17:53
  • @vettipayyan, if Oracle doesn’t provide an official torrent file, then use a torrent search engine such as isoHunt to find a torrent that contains the same file (search for the filename and make sure the filesize matches). Like I said in the other question, point the torrent client to your file and re-hash, then continue it to re-download the missing bits, and discard any extraneous executables (ie cracks, etc.) that may be included in the torrent. – Synetech May 6 '11 at 22:04

I faced the same problem one week ago. I installed Ubuntu 11.04 with IDM, but I found after 10 hours of download that my file had an error in the MD5 checksum.

So my advise to you is to use a torrent link by using any torrent client software like µTorrent, because the torrent download can check and repair an MD5 checksum so you can ensure that your files can be downloaded without errors.

  • No torrent files for that file - i've asked that in Oracle forum - no reply – vettipayyan May 6 '11 at 16:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.