I've been having the weirdest problem with some aspect of my operating system:

enter image description here

This is a screenshot of Google Chrome 11.0.696.57 running in Linux with Xorg server 1.9.5 with the FGLRX display drivers 8.841 on a Radeon HD 4870.

The display drivers, kernel and X server were not upgraded before this started happening. I have also not modified my xorg.conf.

As you can see, the red pixels show up just about anywhere a bitmap is changed. It has been happening in every program and not just the browser. Sometimes they flicker, always appearing at random.

As far as I can tell, the Linux TTY (outside of X) is not affected.

The fact that this is capturable in a screenshot rather than just appearing as pixels on the screen is what puzzles me. If you have any information as to what might be causing this, and hopefully how to solve it, (or even a theory) please post below.

Other information:


Switching TTYs (via ctrl-alt-F[1-9]) and back seems to dissipate the effect, at least temporarily.


I figured out what the problem was, and thought I should post it here just in case it can help someone who may be having similar problems.

The problem was that my graphics card was failing in interesting ways. My guess is that the on-card memory was becoming overheated and failing. This is why no errors came up in Memtest86+; it only scans the RAM and not the video RAM.

I solved the problem by yanking the card. In my case, I had an integrated video card on my motherboard which was almost as good, so I started using that one.

Runs fine now.


Things I'd check:

  • Has anything else been recently updated?
  • Did you install a program recently?
  • How long have the dots been appearing?
  • Do you get them immediately after booting up, logging in, and getting your desktop? Do you get them on the login screen?
  • Do the dots seem to react more to your mouse cursor, or just whenever anything happens or changes on screen?
  • Do the dots overlay the mouse cursor or stay underneath?
  • Have you checked your memory recently? (But I doubt it is a real physical memory issue, or you'd have ridiculous instability as well.)
  • I'd consider the Video Card to be a problem, except that this is capturable in a screenshot. Which means it not only has to be in the video buffer, but it has to be in memory accessible by the screenshot action.

I'm guessing here, but I think there's a few things it might be:

  • An actual process is doing funny things to the display (which would explain why it isn't outside of X11); check ps to see if you have anything strange.
  • A recent change has done something to your video drivers; perhaps reinstall?
  • A recent change has done something to X11. This feels like a compositing issue or an OpenGL issue (if you have any 3D effects enabled on your interface), or even a Video Driver issue. (For example: I can get some pretty wicked results on my Virtualized Ubuntu box when I enable 3D. Haven't tried to get a screenshot from the guest machine, but it wouldn't surprise me if the effects would be copied to the screenshot.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.