1

I am not able to login to Ubuntu. It boots like normal but hangs when showing the wallpaper, without any panels loaded. The cursor is the waiting circle (hourglass equivalent) and nothing happens.

I've set to logon automatically without prompting for password, and before the last restart, I had installed Docky.

EDIT 1: I logged on to console (recovery mode) and removed all startup applications I added from ~/.config/autostart but it didn't help.

EDIT:2 I removed Docky. Still not logging in. Panels are not getting loaded and Alt+F2 doesn't work

How can I fix this problem?

6
  • What kind of graphics card are you using? – boehj May 8 '11 at 11:13
  • Intel default one. not nVidia. BTW, I am not using compiz – softwarematter May 8 '11 at 11:16
  • I just saw your bit about booting to recovery mode - it appeared while I was writing my answer - so it may no longer be applicable. Still, I'd try and remove Docky and see what happens. – boehj May 8 '11 at 11:26
  • Are you attempting to boot into 'Unity' or 'GNOME Classic'? If you're booting into Unity I'd suggest GNOME Classic or whatever it's called. – boehj May 8 '11 at 11:37
  • I am using classic – softwarematter May 8 '11 at 11:44
1

If you think Docky has caused this problem, I'd suggest booting into 'Recovery Mode' in Grub2 and then booting into a CLI environment (I forget how this is worded).

From there you could do:

apt-get remove docky

or whatever the package is called.

Reboot and see if you're in luck.

1
  • I removed Docky. But still it is the same. – softwarematter May 8 '11 at 11:31
1

You can try resetting gnome settings from rescue terminal:

rm -fr .gnome* .gconf*

You will get again the standard gnome configuration when you installed ubuntu for the first time (you will lost wireless passwords too).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.