I tried installing nfs-common on a Ubuntu 10.04 and on a Ubuntu Server 11.04 machines like this:

sudo apt-get install nfs-common

The /etc/init.d/nfs-common script does not get created. Also, the rpc.idmapd daemon did not start because of the /var/lib/nfs/rpc_pipefs/nfs directory missing.

I created the directory in question and idmapd now runs, but when I try to mount an NFS4 filesystem, the UID/GIDs do not get mapped correctly (they get mapped to 4294967294:4294967294), which means that there is a problem with idmapd, but the daemon is running and the configuration on both the server and the client is identical (in /etc/idmapd.conf).

I read that there was a "solved" bug with /etc/init.d/nfs-common not being created, but I am experiencing the issues still on Ubuntu 10.04 and Ubuntu Server 11.04. Does anyone have a solution?


In my case the 4294967294:4294967294 was solved by re-starting the idmap service on both the server and the client.

| improve this answer | |

I can only answer the part about /etc/init.d/nfs-common not being created. Ubuntu has moved from the traditional init to a new system called Upstart. You can manipulate Upstart services using the service command, e.g.:

$ sudo service nfs-kernel-server restart
| improve this answer | |
  • the result is the same regardless of whether I am using service ... or /etc/init.d/nfs... – Shade May 24 '11 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.