Possible Duplicate:
How do I diagnose not being able to reach a specific website as an end user?

Yesterday (Saturday, 7 May) I lost the ability to connect to eclipse.org on my local network; for example, "ping eclipse.org" fails with "unknown host eclipse.org" and "traceroute eclipse.org" fails with "eclipse.org: Name or service not known." I was able to connect to and download from eclipse.org the day before.

I am having no problems connecting to any other web site I usually connect to. I am able to ping and browse eclipse.org from another system on a different isp. I am able to locally ping and traceroute (as determined by "dig eclipse.org" on the remote system, locally dig returns no answer), but traceroute seems to be timing out before it reaches eclipse.org (see below).

Four different systems on local network have failed to connect: debian testing, openbsd 4.8, fedora 14, and archos a43 android tablet. All are connected to a fios router - the first two systems via ethernet, the last two via wifi - which connects to verizon. Power cycling the router and various systems has no effect.

What techniques can I use to figure out what the problem is? I've reserved "contact your isp" as a last-gasp technique, so we needn't consider that further.

For the morbidly curious, here are the traceroutes:

$ date
Sun May  8 11:09:21 EDT 2011

$ traceroute eclipse.org
eclipse.org: Name or service not known
Cannot handle "host" cmdline arg `eclipse.org' on position 1 (argc 1)

$ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1  Wireless_Broadband_Router.home (  0.428 ms  1.492 ms  1.479 ms
 2  L100.NWRKNJ-VFTTP-125.verizon-gni.net (  6.041 ms  6.061 ms  6.565 ms
 3  G5-0-8-1825.NWRKNJ-LCR-08.verizon-gni.net (  8.090 ms  8.739 ms  8.754 ms
 4  so-5-0-0-0.NWRK-BB-RTR2.verizon-gni.net (  11.798 ms  11.818 ms  12.462 ms
 5  0.so-7-1-0.XL4.EWR6.ALTER.NET (  12.363 ms  13.682 ms  13.685 ms
 6  0.so-7-0-0.XL2.NYC1.ALTER.NET (  17.859 ms  12.517 ms  11.207 ms
 7  POS7-0.GW8.NYC1.ALTER.NET (  9.841 ms  10.385 ms  11.123 ms
 8  allstream-gw.customer.alter.net (  46.234 ms  11.353 ms  11.337 ms
 9  ge4-3.hcap4-ott.bb.allstream.net (  26.488 ms  26.510 ms  27.483 ms
10 (  28.169 ms  29.490 ms  29.476 ms
11 (  33.023 ms  33.033 ms  33.640 ms
12 (  30.087 ms  30.571 ms  31.220 ms
13  * * *
[ blah blah blah ]
30  * * *


marked as duplicate by Sathya May 9 '11 at 4:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 1 down vote accepted

Have you tried using an alternative DNS like Google DNS or OpenDNS? You would need to change those in your router's settings.

Their addresses would be, respectively:


Judging from the fact that

  1. you can't reach a domain but the IP
  2. all machines are affected because they use the router's DNS entry
  3. browsing from another ISP works

this is the most likely solution.

  • Moving to Google's dns resolvers solved the problem; thanks for your response. – r. clayton May 8 '11 at 19:36
  • Not a thing. Please consider accepting the answer so the question is closed. – slhck May 8 '11 at 19:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.