During normal use of Java applications (including the Java configuration application accessed via Control Panel), my screen goes black and after a few seconds I get the error "Display driver stopped responding and has recovered." Even when it doesn't totally crash my display drivers, large parts of the UI are often black and it's almost completely unusable. I have tried reinstalling the latest version of my display drivers and reinstalling Java (currently just the 32-bit version since it's a 32-bit application I want to run). Has anyone seen this or have an idea of what might be happening? Here are the relevant specs:

  • Windows 7 Home Premium 64-bit
  • Radeon HD 5770 - Driver version 8.841.0.0
  • Java Version 6 Update 25 (build 1.6.0_25-b06)

I will edit as I try more things. Suggestions of possible problems are welcome.


I tried removing the 32-bit version of Java and installing the 64-bit version (even though they should exist fine side-by-side, I wanted as few variables as possible). When editing the settings in the Java Control Panel, the drivers no longer stop responding when I click on "View..." under Temporary Internet Files, but there's definitely still something wrong, as shown by this screenshot:

Java Screenshot

Edit 2:

Everything appears to work fine with nothing but driver version 8.782.0.0 installed (in other words, no Catalyst Control Center or OpenCL drivers and an older version of the drivers). I'm going to try installing the latest driver version without the additional software and see if that works as well.

Edit 3:

Everything seems to be working fine with the latest display driver only installed. I am now going to attempt to narrow down exactly what else in the Catalyst Control Center install would be causing the problem. My current suspect is the OpenCL drivers or APP SDK or something along those lines.

| improve this question | | | | |

I have narrowed it down. It wasn't caused by any of the drivers or the APP SDK or anything like that. It was being caused by the ATI Catalyst Control Center installation (either that, or one of the default settings that is set by the Catalyst Control Center).

Since I didn't really need Catalyst Control Center for anything, I removed it. Now everything looks like it's working fine, but I am going to file a bug report with AMD.

| improve this answer | | | | |
  • Nevermind, I can't figure out how to submit a ticket to AMD... Spent 10 minutes searching; any more time wasted is not worth it. If someone can tell me where to go, I'll do it. – Steven Oxley May 8 '11 at 21:08
  • uninstalling Catalyst Control Center worked perfectly for me – mcmillab Sep 14 '15 at 6:52

I have a very similar problem using Radeon X700 on Win XP. I nailed it down to the fact that it only happens since Java 6 Upd 8 (yes I know, very old aready). If I run an Java application with Java 6 Upd 7 (1.6.0_07), then it runs fine. Running the same application with a current Java 6 version, it crashes the display driver with the same symptoms reported in this thread. I did not try wioth Java 7 yet.

| improve this answer | | | | |
  • 1
    trial and error, good choice: Java must break the drivers. Tried updating them? – Simon Sheehan Jan 5 '12 at 20:51

Try with these run time flags.


These flags toggle the OpenGL pipeline, turn of using Direct3D and disable use of DirectDraw respectively.

| improve this answer | | | | |
  • This solution worked for me in Windows 7 with java 1.4 – IK01 Mar 15 '12 at 15:12

From what I discovered, open up Catalyst Control Center, go to Gaming > 3D Application Settings.

Then check the "Use application settings" under Anti-Aliasing would fix the Java graphic glitch as well as display driver crashing problem.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.