7

I use kate (a KDE text editor) under GNOME in Ubuntu. Since Natty upgrade, it plays miscellaneous sounds on error and other notifications.

I disabled sound notifications in GNOME, but kate sounds are still played. Kate itself doesn't seem to have any sound configuration, and I can't find any KDE configuration tool in the system menus.

How can I disable KDE notification sounds in a GNOME Ubuntu?

5

Install KDE settings package sudo apt-get install systemsettings. Then open it up and go to Application and System Notifications, Player Settings tab, set No audio output.

  • My systemsettings doesn't have Application and System Notifications. It has: * Workspace - Desktop Behavior - Shortcuts * Personalization - Regional Settings * Network - Settings - Connectivity * Hardware – Chelmite Sep 15 '16 at 1:15
2

I do not see a reason for these bloody noises anyway. My solution that requires no installation of any more applications to take up space is to just delete the bloody noises: sudo rm -fv `sudo find /usr/share -iname *.ogg`

  • 2
    Might want to limit that search path a bit to avoid deleting other sounds as well, but otherwise a good answer - Simplicity works! – Jarmund May 22 '15 at 22:12
1

The previous answer is rather overkill as it will mute everything, not just the error beeps, in KDE and prevent you from hearing things you actually want to hear.

Instead of going to the Player Settings tab, the individual error noises can be disabled in the Applications tab.

  • 2
    Unfortunately that requires you to individually silence about 500 different beep noises in twenty different places. There really needs to be a 'disable all' button. – David Given Oct 26 '14 at 18:11
0

In case of Linux Mint 18.3 installing systemsettings didn't work, because the settings window was empty. Here I've found that the following is sufficient without installing additional packages (besides Krusader that I already had installed):

kcmshell4 kcmnotify

Then Player Settings -> No audio output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.