Yesterday I freshly installed Ubuntu 11.04 (Natty Narwhal) 32bit on my laptop but couldn't install Google Chrome on it. Google Chrome was working fine with my previous Ubuntu 10.04. While I tried to install the package I downloaded from Google Chrome site,

$ sudo dpkg -i google-chrome-stable_current_i386.deb

It shows the following error-

Selecting previously deselected package google-chrome-stable.
(Reading database ... 135527 files and directories currently installed.)
Unpacking google-chrome-stable (from google-chrome-stable_current_i386.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libnspr4-0d (>= 4.7.1); however:
  Package libnspr4-0d is not installed.
 google-chrome-stable depends on libnss3-1d (>= 3.12.3); however:
  Package libnss3-1d is not installed.
dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:

When I tried to install libnss3-1d manually, it returns broken package error

The following packages have unmet dependencies:
 libnss3-1d : Depends: libnss3 (= 3.12.9~b2-0ubuntu1) but 3.12.9+ckbi-1.82-0ubuntu2 is to be installed
E: Broken packages

Any help?

  • have you tried downloading from ubuntu software center?
    – mic84
    May 9, 2011 at 12:19
  • ubuntu software center chromium, the open source version. I wanted to use the Google release version.
    – Yeameen
    May 9, 2011 at 15:48

2 Answers 2


I got the same error and tried different things. Also tried installing libnss3-1d.

Finally succeeded when I installed libnspr4-0d

sudo apt-get install libnspr4-0d 
  • Thanks, this worked for me. I tried this before but it was failing because my repo list (bd.ubuntu.com) wasn't updated. Later I pointed to US server and it works :)
    – Yeameen
    May 12, 2011 at 11:49

That rather obtuse answer is how dpkg announces a dependency conflict. ("X won't be installed because it requires Y which can't be installed at the same time as Z and Z is required by something you already have")

My best guess is that you're trying to install a Chrome package for a different version of Ubuntu. (Which doesn't work. .debs are very specific about their dependencies)

Can you elaborate on why you feel Chromium isn't a suitable alternative to Chrome?

  • Google provides a single .deb file. So I couldn't find any alternative.
    – Yeameen
    May 11, 2011 at 6:47
  • I am opted to use Google chrome over chromium because Google release is suppose to be more stable and tested
    – Yeameen
    May 11, 2011 at 6:48
  • Yeah. Google really tries to oversimplify their Linux offerings to the point that the .deb will handle adding their repo without asking you (to replicate the Windows version's "Don't ask. Just silently upgrade." behaviour as closely as possible). As for stability, I haven't found it to be a problem. In fact, on Gentoo, if anything, Chromium is more stable because the ebuild which compiles it is written by people who know about potential problem points in Gentoo.
    – ssokolow
    May 11, 2011 at 17:02
  • Once I used to use chromium when Chrome wasn't officially released for Linux. But that crashes very often. Surely Google doesn't care as much as their Windows and Mac users, but when I installed Chrome after all these the problems are gone. Since then I have been using Chrome.
    – Yeameen
    May 12, 2011 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.