Typing "www.example.com" works fine in IE8, but when I enter "www.example.com:8000" it doesn't work (I know it works for some people).

Port 8000 is necessary because I do a lot of web development testing and I run web servers on that port.

The error I get reads:

The webpage cannot be displayed.
Most likely cause: Some content or files on this web page require a program that you don't have installed.

Of course, on the same Windows machine Chrome and Firefox both work perfectly fine.

up vote 17 down vote accepted

IE is finicky when it comes to adding port numbers - if you want to use them, you MUST add http:// at the front, so try http://www.example.com:port

  • This is actually fairly obvious: www.example.com:8000 means using a protocol called www.example.com to resolve the identifier 8000. URLs that lack a colon (and hence a protocol designator) are special-cased to use HTTP (or FTP, if the name begins with "ftp.". – Simon Richter May 9 '11 at 12:16
  • 1
    It's IE being a bit pedantic - other browsers work out what you're trying to do without any fuss. – Linker3000 May 9 '11 at 12:58

There are probably some privacy or policy settings getting in the way. Third party applications tend to ignore these settings, so only Microsoft's applications are usually implement them.

To update your Privacy settings: Control Panel -> Internet Options -> "Security" and "Privacy" tabs (I'm not sure which options, but I suspect that these would be two good places to look)

To update your Policy settings: Contact your local network administrator if you're in a corporate environment, or see the following web page for information on getting into the Local Policy Editor: http://support.microsoft.com/kb/307882

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.