77

There is a folder that is owned by user tomcat6:

drwxr-xr-x 2 tomcat6 tomcat6 69632 2011-05-06 03:43 document

I want to allow another user (ruser) write permissions on document folder. The two users (tomcat6 and ruser) does not belong to same group. I have tried using setfacl:

sudo setfacl -m  u:ruser:rwx document

but this gives me setfacl: document: Operation not supported error. Kindly help me.

138

There are two ways to do this: set the directory to "world" writable or create a new group for the two users and make the directory writeable to that group.

Obviously making it world writeable is a Bad Thing, so the second option is preferable.

Users in Linux can belong to more than one group. In this case you want to create a brand new group, let's call it tomandruser:

sudo groupadd tomandruser

Now that the group exists, add the two users to it:

sudo usermod -a -G tomandruser tomcat6
sudo usermod -a -G tomandruser ruser

Now all that's left is to set the permissions on the directory:

sudo chgrp -R tomandruser /path/to/the/directory
sudo chmod -R 770 /path/to/the/directory

Now only members of the tomandruser group can read, write, or execute anything within the directory. Note the -R argument to the chmod and chgrp commands: this tells them to recurse into every sub directory of the target directory and modify every file and directory it finds.

You may also want to change 770 to something like 774 if you want others to be able to read the files, 775 if you want others to read and execute the files, etc. Group assignment changes won't take effect until the users log out and back in.

If you also want (you probably do) that new files created inside the directory by one of the users are automaticaly writable by others in the group, then see here.

  • 2
    You probably want to also set the set-group-ID flag for directories, to make new files and sub-directories automatically owned by the right group: sudo find /path/to/the/directory -type d -exec chmod 2770 '{}' \; – Marcello Nuccio Dec 13 '12 at 14:28
  • 8
    I'd avoid using chmod 770, 775 or whatever. That messes with the permissions of all files. Instead use something like chmod -R g+w to add write permissions without mucking up everything else. – Christian Varga Jan 3 '13 at 15:11
  • 2
    If a user creates a new file there (say, mysql by SELECT INTO OUTFILE), it sets permissions to its primary group (mysql in this case), and the file is not accessible by another user anyway. How to workaround this? – Olexa May 15 '13 at 11:53
  • 2
    What if you want to grant users write access to a folder without changing the folder's ownership e.g. you don't want to mess with apache's permissions on a public_html folder? – codecowboy Feb 12 '14 at 16:45
  • 1
    Note: "Group assignment changes won't take effect until the users log out and back in." I have missed that :) – Vladimir Vukanac Dec 4 '15 at 11:50
2

Example script shows an example to give w (write)/ r (read) / x (execute) permission to the given folder path /path/to/the/directory for USER1 and USER2. If you want to give only write access please replace rwx with w.


#!/bin/bash

# Block others and people in the same group to do read/write/execute on give folder:    
sudo chmod 700 /path/to/the/directory 

#Give read/write/execute access to USER1 on give folder:
sudo setfacl -R -m user:USER1:rwx  /path/to/the/directory 

#Give read/write/execute access to USER2 on give folder:
sudo setfacl -R -m user:USER2:rwx  /path/to/the/directory 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.