I've installed Ubuntu 11.04 and the new scrollbars in Nautilus, GEdit, etc. are driving me insane! How do I go back to the old (Ubuntu 10.10 and earlier) scrollbars?

In the Natty Nautilus you can't actually see a scrollbar normally. Instead you mouse over to where it should be (to the left of the border) and then it appears, but it doesn't appear under the mouse pointer! Instead it appears to the side (to the right of the border), so starting to scroll is now a fairly involved mouse manoeuvre. I don't know what UX genius came up with this, but I want none of it.

  • 2
    @BlueRaja: It's not as bad as this makes it out to be, although it could use some ironing out. The grab target activating at the same time the floating grab handle activates is frustrating. Otherwise, the scroll location actually is visible and the grab handle is usable anywhere in the range of the current scroll area.
    – Caleb
    May 9, 2011 at 17:03
  • 1
    I for one think it is GREAT! You no longer have to worry as to where the scroll bar is. Sometimes when you have pages of text, firefox et al. make the scrollbar so tiny that it's hard to grab it. Here you can easily grab it by just moving to the right, and it's the same size no matter how much text.
    – user70365
    May 15, 2011 at 21:06

3 Answers 3


This site mentions a way to do this:

sudo apt-get remove overlay-scrollbar
sudo su
echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars

A system restart required

It's also possible to run:

sudo -i
apt-get remove overlay-scrollbar
echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars

Scrollbars instantly appeared! "sudo -i" puts the whole terminal window into an interactive root environment, so you only have to enter your password once. "sudo su" appears to do the same thing.

  • 2
    I found that just removing the overlay-scrollbar package is enough to get rid of them. May 9, 2011 at 16:51
  • Great, thank you! Just removing overlay-scorllbar was not enough in my case, I had to do the other step as well.
    – EMP
    May 11, 2011 at 0:30
  • 3
    – Hello71
    May 15, 2011 at 0:44
  • Presumably the sudo su was done to then do the echo with redirection to a root-only file. An alterantive is echo LIBwhatever | sudo tee /etc/X11/whatever, which avoids using the shell redirection and sidesteps the need for su. Jun 19, 2011 at 19:01
  • Thanks for this as it was driving me absolutely mad, although I find the need for a restart very 'Windows'-ish.
    – JeeBee
    Feb 16, 2012 at 11:10

The easy way is to open Synaptic Package manager, scroll down to Liboverlay_scrollbar then mark it for complete removal and then Apply. Once Synaptic finishes, close it out and the old Gnome scrollbar will b be restored.

Edit: Command-line version:

sudo apt-get autoremove --purge 'liboverlay-scrollbar-*'
#single quotes avoid shell glob-expansion
  • 2
    Great, that works and it's even simpler. Thanks! I've added the command line equivalent.
    – EMP
    May 15, 2011 at 0:26

Did anyone mention restarting your machine afterwards? Just restarting Nautilus won't do it.

From WebUpd8:

So, for everyone searching for this, here's how to disable the overlay scrollbars in Ubuntu 11.04. Simply open a terminal and copy/paste the following commands:

sudo su
echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars

Then restart your computer.


Not the answer you're looking for? Browse other questions tagged or ask your own question.