1

Possible Duplicate:
Skype crashes when I login

Host OS: Windows 7 Prof SP1 x64 (MSDNAA Campus)  
CPU: Core i7 950 @ 3.06ghz HT:OFF | Turbo: ON  
Mem: 3x2gb Kingston 2000mhz DDR3 Triple-channel (all-OK, memtest: 100% OK)  
HDD: 2x500gb WD Black Caviar 7200RPM RAID0 - Marvell RAID Controller  
PSU: Corsair Enthusiast Series 750W V2  

The system is clearly not overloaded, the load is about 0.00, 0.01 if I would be on Linux.
Skype crashes RIGHT after I start it. Yesterday, it was perfectly fine. Today when I launched the app, it said its installing something. Sure, why not. When it finished, crash thingie came up. Tried reinstalling it 100%, no success.

Any ideas?

Debug (No JIT installed right now / yet):

Problem signature:
  Problem Event Name:   BEX
  Application Name: Skype.exe
  Application Version:  5.3.0.111
  Application Timestamp:    4dac4a84
  Fault Module Name:    StackHash_e98d
  Fault Module Version: 0.0.0.0
  Fault Module Timestamp:   00000000
  Exception Offset: 00000000
  Exception Code:   c0000005
  Exception Data:   00000008
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1: e98d
  Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
  Additional Information 3: 6eab
  Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
  • 2
    Yeah, I know. "Have you tried turning it off and on again?" ... >.> – Apache May 10 '11 at 10:20
3

Same happened to me today after an update. I fixed it by DISABLING the "Vista compatibility mode" option, which I had set.

Instructions: right-click over program icon, Properties->Compatibility UNCHECK the checkbox "Run this program in compatibility mode for..."

Worked for me.

Note: I had set previously the Vista compat mode to get the old behaviour of puting the skype icon in the alert area (instead of the taskbar) when minimized. Bot this can now be done in the Options->Advanced->Keep Skype in taskbar... (uncheck)

BTW: I had this crash (first in my Skype) minutes after knowing about MS buying Skype... but it seems it was just a coincidence :-)

| improve this answer | |
  • 1
    Oh thanks. +1 for the coincidence. :D – Apache May 10 '11 at 19:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.