I have a nice bluetooth headset Plantronics 590 and I really want to use it in Linux the way I use it in Windows, i.e. listen to music and call through Skype. There's tons of tutorials how to make either of those usages work but not one describe how to make them both work. Another problem is that bluethooth headset support in Linux advances pretty rapidly so most of those tutorials are outdated. For example, pulse audio does support bluetooth out of the box now so editing .asoundrc is not necessary.

What I want is a tutorial about how can I pair my bluetooth headset with latest Ubuntu (9.04), so I can play music through A2DP profile, how can I pair it in a way so I can use Skype with it (through mono profile with mic) and how do I switch between this ways of pairing with restarting as little things as possible.

  • The best tutorial should win.
    – vava
    Aug 25, 2009 at 11:57
  • 1
    my limited experience was that bluetooth is terrible (distance/quality) compared to wireless headset solutions, which isn't relevant but might be of interest... if I'm right. Aug 28, 2009 at 15:57
  • I don't care much about the sound, it has good enough quality for me. But being able to use them with skype is very handy. My wife calls only from my computer since I bought them :)
    – vava
    Aug 29, 2009 at 7:01

2 Answers 2


This is really strange world. Recently new skype 2.1 beta came out and I rushed to install it and see how it works. Now my headphones works beautifully although I'm not sure why :) Nothing except skype has changed but my stereo sound magically got fixed too.

My setup is: PulseAudio 0.9.15, bluez 4.41, Skype 2.1 beta (from official site for Ubuntu 8.10 32bit) and blueman 1.10. Skype works entirely through PulseAudio, in fact it can't work any other way.

After pairing my headphones I have one new device in PulseAudio. In configuration tab for this device I can choose the profile, either mono (and then I can use it as audio sink or source) or stereo (only sink is visible). In mono mode it works with skype, in stereo it sounds good. And I don't have to restart anything :) Although there's a twist, stereo sink is much much more quiet than mono sink, when I disconnect from skype and change my headphones to stereo at first I thought my sound got missing but it just was too quiet to hear anything.

If you're going to use blueman with pulseaudion 0.9.15 like I do, make sure you have PulseAudio plugin for it turned off (Bluetooth applet right-click -> about -> Plugins). If it is turned on as some sites on the internet suggests, it creates additional device in PulseAudio so you have two of them instead of just one and those devices could not work together anyway.

Also make sure you have pulseaudio-module-bluetooth installed, in 0.9.14 it was statically linked into PulseAudio but in 0.9.15 it is additional package.

Another trick is that Skype is not listed in Recoding tab in PulseAudio Volume control, but if you look in right down corner there's a combobox, select 'Streams' there and voilà, Skype is there and you can move that stream to your bluetooth headset.

So it works, I'm happy :) Have to move everything to Linux now :)


Well Ubuntu 9.04 comes with Pulseaudio and my Plantronics Voyager 520 works fine with Skype by just connecting it over the Bluetooth Icon in the Gnome taskbar (Bluetooth Icon Right click -> Set up new device... then Pair with Headset, PIN is usually 0000 and then set trust mode in the preferences). After choosing headset as the sound device in the Skype options the test call was working without problems.

In 8.10 it didn't work right away but by I could make the headset available in Skype by following this tutorial.

  • This is where problems are coming from, your headset is mono only, bluez knows exactly how to connect it. Mine is stereo + mono, something on the computer should switch it from one mode to another, from listening to music to working with skype.
    – vava
    Aug 24, 2009 at 0:28
  • Hm you're right. Does it at least connect and play mono?
    – Daff
    Aug 24, 2009 at 9:49
  • :) It is hard to say as I have updated Pulse Audio and installed Blueman. Last time I tried it couldn't do anything, Pulse Audio starts to use 100% of CPU and eventually pairing gets broken. But I do remember making it work in stereo, I even remember making it work with Skype. Switching from one way to another though required me to restart my computer which is not good :)
    – vava
    Aug 24, 2009 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.