I'm trying to convert an .iso file (Ubuntu disc image) to a .img file.

I run a command like so:

hdiutil convert -format UDRW -o ubuntu.img ubuntu-11.04-server-amd64.iso

But no matter what, I get the error: hdiutil: convert failed - not recognized

I'm not sure how to resolve this problem or how else I can convert. Any help?

  • 2
    Are you sure the iso is not corrupt? Are you able to mount the iso? – h0tw1r3 May 11 '11 at 4:18
  • Works for me. I second @h0tw1r3's suspicion that the iso file is broken. – Daniel Beck May 11 '11 at 5:38

I had this same problem while trying to create an Ubuntu Server USB disk from a downloaded .iso file. Taking h0tw1r3's advice, I ran md5 ~/path/to/ubuntu-server.iso and it came back with a different value than the one found on the UbuntuHashes wiki page, indicating that my download was a "corrupted" .iso file.

To fix it, I opened the .torrent file from the Alternative Downloads page in Transmission, which automatically scanned the corrupt file in my Downloads folder, figured out what I was missing, and corrected the file by downloading only those parts. Three cheers for bittorrent!

| improve this answer | |
  • +1 for mentioning the use of BitTorrent in only re-downloading the broken parts of the file. – afrazier Sep 29 '11 at 13:25

I had the same problem and even ran md5 check which was successful, the problem was the order of the parameters in the command.

Try this:

hdiutil convert ubuntu-11.04-server-amd64.iso -format UDRW -o ubuntu.img
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.