1

My laptop (an Acer Aspire 5630) has the F1, F2, and esc keys broken. I need to change the boot sequence so I can install an operating system but I can't get into the BIOS to tweak that parameter.

What can I do?

I thought about resetting the CMOS hoping that at the next boot It'll force me into bios to check wrong parameters.

Maybe also flashing a new BIOS (if it's possible from the operating system) could trigger me at the next boot to the BIOS to tweak the boot sequence parameter.

Any ideas?

Other Details

  • USB keyboard is not working before operating system boot

  • No PS/2 ports on board

  • 1
    have you tried plugging in a usb keyboard ? – Shekhar May 12 '11 at 9:39
  • I'm sorry I didn't mention it: yes. Of course not working :( – Pitto May 12 '11 at 9:44
  • ps no ps/2 port on board – Pitto May 12 '11 at 9:44
8

Replace the keyboard.

$12 problem solved. Stop looking for workarounds and fix the real problem.

  • you got quite a point... I'm just scared thinking about small torx screws anywhere :) – Pitto May 12 '11 at 10:09
  • I think he's saying that he doesn't have the USB keyboard option turned on in the BIOS so the integrated one is all he can use. – Blomkvist May 12 '11 at 10:47
  • 1
    @Blomkvist - I think you're right, which is why I upvoted this answer. He HAS to replace the internal keyboard, there's really no (easy or reasonable) way around it at this point. – Shinrai May 12 '11 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.