Chrome is running all of it's tabs in a single process, and when I open a large number of tabs it really slows down my machine. Considering Chrome's original marketing played up running each tab as a single process, I was surprised to find out that Chrome no longer does this.

I tried the --proccess-per-tab flag, but I got an error (-43 to be exact).

The argument I tried was

open -a /Applications/Google_Chrome.app/Contents/MacOS/Google_Chrome --args --process-per-tab

Running Mac OS 10.6.7 and Chrome 13.0.761.0

Update: Just opened chrome, and its grouping my tabs into 4 different processes.

tab list

As time goes on, the processes will merge into one.

  • Check about:memory in Google Chrome and open various tabs and see if it really lumps all the processes into one.
    – paradd0x
    May 13 '11 at 20:49

You should usually open an application bundle, not the actual binary within. So I suggest you use:

open -a "Google Chrome" --args --process-per-tab

open -a "/Applications/Google Chrome.app" --args --process-per-tab

Nevertheless, I cannot reproduce the issue with either Chrome 11, 12 (beta) or 13 (dev).

Activity Monitor output when using Chrome 13.0.761.0 dev, launched as open -a "/Users/danielbeck/Applications/Google Chrome 13.app" --args --process-per-tab:

enter image description here

After demonstrating that there's no issue with Chrome, here's what you did wrong:

You simply specified the wrong path. There are no underscores, only spaces, escaped by a leading \ or wrapped in quotation marks.

Wrong: open -a /Applications/Google_Chrome.app/Contents/MacOS/Google_Chrome --args --process-per-tab
Right: open -a /Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --args --process-per-tab
Alternative: open -a "/Applications/Google Chrome.app/Contents/MacOS/Google Chrome" --args --process-per-tab

For future reference: Tab-completion properly escapes spaces. You should be able to type /A[tab]Goo[tab][tab]Ma[tab][tab] and it'll work.

  • 1
    I'm not going to remove the useless stuff at the beginning, as it took me long enough to figure out the real cause of the problem: PEBCAK.
    – Daniel Beck
    May 13 '11 at 21:04

I have noticed that Chrome shares processes when you right click on a URL and click "Open in new Window" instead of using a new tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.