I'm writing this from a Ubuntu CD installation, because I upgraded my video card drivers and now I can't boot anymore in Widows...

My video card is GeForce 8600M GT, and the drivers to which I updated are 270.61 (from 260). After I installed them I didn't restart normally because the installation program didn't ask... A little later my computer hanged (for some other reason) so I had to force shut down by holding the power button pressed.

Then after I power it up again, just before the Windows welcome screen the computer freezes and I see random characters on the screen and start hearing some high pitched sounds which I think is the hard drive working more than usual (it's a SSD).

I tried safe mode but the same happens after the loading drivers message...

So how can I delete/disable the nvidia drivers in my Windows installation from Ubuntu? I don't want to re-install Windows...


A. Try booting into Safe Mode and uninstall the Driver. Press F8 and select SafeMode with Networking. Try this post. It will only load essential drivers (and that does not include any type of display drivers) (PS: I see you said SafeMode did not work but added this just for completeness. You can always try once more :) )

B. If you have the original Windows 7 DVD, you can try repairing your Windows Installation.

C. In case you don't have the original DVD, you can create a System Repair Disc from another Windows 7 machine, boot your machine from it and repair the installation.

| improve this answer | |
  • I used the Windows installation disk, clicked on repair your computer and it worked! I think it was a hard disk problem because during the "computer repairing" it said it was fixing hard disk errors... Tx! – Alex May 14 '11 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.