Ok, I finally installed Windows 7, clean install. Time synchronization does not work. Clicking "Update now" gives message:

Unable to start the Windows Time service. Please try again later.

I use time.nist.gov, as I believe that use to be reliable, and works for my XP pc's.

Any hints on this?

I did edit the Task Scheduler,

Microsoft > Windows > Time Synchronization > SynchronizeTime

where I set it to synch every 6 hour (I need accurate clock), but this problem was also before I made that change. And this scheduler doesn't set the time either, as far as I can see..


3 Answers 3


It seems that Windows Time Service could not be started.

  1. Check if Windows Time Service is disabled. If yes enable it and set it to Automatic (open Run prompt and type "services.msc".Navigate to Windows Time, right click, select Properties and change Startup to Automatic).

  2. Try manually starting Windows Time Service (open Run prompt and type "services.msc"). Navigate to Windows Time right click and click Start. If it does not start properly, check the event log for the error.

If there is an error in the event log, update the question with the error.

UPDATE: Try http://www.worldtimeserver.com/atomic-clock/ first.

  • The error messages usually get dumped to Event Log, at eventvwr.msc. May 14, 2011 at 14:18
  • Ok, it was set to Manual, and was not running. So I sat it to Automatic, and started it. However, I still get the same error. Do I need to restart my system? Not sure where to look in the Event Log, I never used that before.
    – bretddog
    May 14, 2011 at 14:28
  • Open Run Prompt. Type eventvwr. Click on Application. See if any error is logged. Now click on System. See if any error is logged.
    – Ganesh R.
    May 14, 2011 at 14:31
  • Hmm. I can't see any related errors. Is this windows Time Service supposed to run all the time? Even though I set it to automatic, after system restart, it still is not started. Then when I start it, and go to the Internet Time Settings dialog, it says time was updated (at that time), however time is still incorrect. And still gives the error message when I try to Update now manually.
    – bretddog
    May 14, 2011 at 15:00
  • Windows Time runs all the time. Can you check if it is running under LocalSystem account? You can do this in services.msc
    – Ganesh R.
    May 14, 2011 at 15:06

Very late answer here ...

After many failed attempts to sync with various time servers I came to realize time sync problems were caused for lack of an initial sync reference point. After manually synchronizing from cmd|posh I was then able to use the gui app to sync ...

Powershell ...

 cd $env:systemroot\System32 

 .\net stop w32time
 .\w32tm /unregister 
 .\w32tm /register
 .\sc config w32time type= own
 .\net start w32time
 .\w32tm /resync /computer:$env:COMPUTERNAME    

You should get a response such as ...

Sending resync command to {$computername} ...

Afterwards the gui interface should succeed ...

  • 1
    The w32tm /unregister command gives me Access denied errors. Any idea why? Mar 30, 2014 at 16:39
  • @MatheusMoreira Are you in an elevated prompt? Mar 30, 2014 at 19:40
  • I suppose. I'm on an administrator account, and it doesn't seem to work even if I right click and select "Run as administrator". Mar 30, 2014 at 19:42
  • Is the service running? @SEE Ganesh's answer to ensure the service is actually running... > administrator > services.msc ... Mar 30, 2014 at 19:48
  • The service is running. Mar 30, 2014 at 19:56

I got the same error "Access is Denied"; however using Microsoft's Fixit available at this MS Fixit a synchronisation mode became available in the Tab "Internet Time" where I was able to sync manually (tho it automatically syncs on a schedule) and change time servers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .