I have a QNAP NAS that offers a few SMB shares. As I'm in a trusted environment, my shares are accessible as guest rather than with a combination of username and password.


Now, when I click the name of the device in Finder's sidebar, I get the black "Connection failed" bar, with the option "Connect as...". When I click that, I receive:

enter image description here

I can however press  + K and enter the server's name manually, which gets me to this window:

enter image description here

Here, I have to select "guest". Now, I can select one of the shares to connect to, and I'm finally connected to the server. If I select it in the sidebar, I get a list of all shares available, because I'm connected as "guest", obviously:

enter image description here

What I need

Well, as soon as I unmount all shares, I have to go through the same procedure of manually logging in as "guest" again, which I find quite annoying.

Is there any way I could get Finder (or the underlying SMB client) to know which credentials to use?

Or should I look for the solution rather on the server side? (I know that other SMB shares seem to work fine in my network)


The only thing I can get out of Console.app is:

5/15/11 7:36:40 PM  /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder[200]  SharePointBrowser::handleOpenCallBack returned 64

This message occurs when I click the name of the SMB server in the Finder sidebar.

Here's the output of `smbclient -L meredith -U guest -d=2

charon:~ werner$ smbclient -L meredith -U guest -d=2
added interface ip= bcast= nmask=
tdb(unnamed): tdb_open_ex: could not open file /private/var/samba/gencache.tdb: Permission denied
Got a positive name query response from ( )
Domain=[MEREDITH] OS=[Unix] Server=[Samba 3.5.2]

    Sharename       Type      Comment
    ---------       ----      -------
    music           Disk      
    movies          Disk      
    photos          Disk      
    software        Disk      
    archive         Disk      
    backups         Disk      
    IPC$            IPC       IPC Service (NAS Server)
Got a positive name query response from ( )
Domain=[MEREDITH] OS=[Unix] Server=[Samba 3.5.2]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

Also, things I've tried:

  • There is no relevant entry in the Keychain (but why would it, I'm only connecting as guest)
  • Connecting with user name "Guest" and empty password logs me in but still after ejecting the last share, I get the same "Connection failed" error as before. The appropriate entry is made in the Keychain but obviously has no effect.



In Mac OS X 10.7.3, I used the following string in Finder's "Connect To Server..." (Command-K) for a similar server in my office:


You need both the ':' and "@". I believe it works out as UserName:Password@address .

After the volume appeared, I tried to put it in my shortcut bar, but it wouldn't stay.

I made an alias, and tested it after disconnecting. It worked fine. No window appeared to choose "Guest".

  • This also worked great for me to stop OSX automatically logging in as Guest, by adding username:@ before the host name, as you've said. Thanks. Jan 27 '15 at 22:03

This is probably what is happening to you: Finder will try to connect to your share using AFP instead of SMB, if unconnected and both daemons are running on the server and AFP is being advertised via Zeroconf. Not advertising AFP using Zeroconf (avahi/whatever) should fix this. Time Machine should still work.


Create a file called ~/Library/Preferences/nsmb.conf and add to it:


Disconnect from your server, reconnect and try again. This worked for me (I had the same problem).

Found it at http://ubuntuforums.org/archive/index.php/t-917156.html


Here's an article from Apple that should fix this.

  • Nope, the article is for OS X 10.3 and dates from October 2008. Also, I can't store a username/password when I'm connecting as guest.
    – slhck
    May 19 '11 at 20:59
  • Check the Keychain Access app (Applications > Utilities > Keychain Access). It'll be in there somewhere.
    – Smurf64
    May 19 '11 at 21:00
  • 1
    No, unfortunately there is no entry for the host. I've already tried looking there. As said before, the Keychain won't store entries for guests.
    – slhck
    May 19 '11 at 21:03
  • Try typing "Guest" with a blank password and check the Remember password box.
    – Smurf64
    May 19 '11 at 21:08
  • That was a good idea, but still doesn't work.
    – slhck
    May 19 '11 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.