I tried the "Erase the Solid State Drive in the HDD bay" BIOS feature following these instructions. The message "Now erasing... It may take about 6 minutes." came up. After waiting over three hours, I dismissed the warning to not turn off the laptop. (There wasn't much else I could do.)

Now my X301 laptop just hangs at boot. I can't even get into BIOS setup or select a boot device. I think what happened to me is similar to this story, however, I can't even tell if my SSD is password-locked.

If I physically disconnect the SSD, I am able to get into the BIOS setup and even select a boot device. The laptop functions fine when booted to Ubuntu installed on a USB drive. So I am pretty sure the problem is with the SSD. Thus the questions are, "Did Lenovo BIOS secure erase brick my SSD, and how do I make the SSD functional again?"

  • 1
    Call Lenovo support, and get them to replace the drive. – Shinrai May 17 '11 at 17:26
  • @Shinrai: that's what I ended up doing. They just replaced the SSD; I'm not sure if they tried to recover the old one. I asked how to do the secure erase properly next time, and they said to bring the laptop in and they'll do it... – Leftium Jun 8 '11 at 7:34
  • 2
    Trust me, they didn't try to recover the old one. :) – Shinrai Jun 8 '11 at 13:47

I have seen similar issues in the past.

On some motherboards, the detecting hard drive / hard drive auto discovery stage can hang if a hard drive is corrupt, badly formatted or damaged in some way.

If you pulled the drive whilst it was in the middle of an operation, anything is possible and anything would be a guess.

My guess based on previous experience is that it has become corrupt and as I said, failing the discovery stage of the BIOS. If your BIOS and the port support hot swap, I would recommend putting the drive in after you have gone over that step and seeing if you can reformat the drive.

(Personally, I came up with something similar on Gigabyte motherboards with hard drives after turning on AHCI mode, formatting from another machine after hot-swapping worked fine).

  • An usb drive cradle may be required to fix the drive. You'll likely have to reformat. – Jeff F. May 17 '11 at 17:39
  • You could try getting a firmware update utility for your SSD, and a Windows PE startup CD. Boot into Windows PE with your SSD connected. After Windows PE boots, connect the SSD (SATA is hot swappable) and try to update the firmware. This is assuming the laptop boots without the SSD connected. – LawrenceC Sep 18 '11 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.