How do I find out what is blocking my ports? I am on Windows 7 x64 and trying to run Minecraft on port 25565, which worked yesterday, but not today. I have not installed any new software.

I have tried disabling Windows firewall, and I previously added two days ago a port forwarding setting to my modem. Since it worked yesterday I don't think it has to do with my ISP.

  • Are you sure that the port is blocked? Remember that you get a new public ip every day. (unless you have got a persistant ip) – Michael K May 18 '11 at 15:43
  • Leases on Public IPs are not usually set for one day. – music2myear May 18 '11 at 15:59
  • @Michael: yes, I'm sure, I'm not utterly stupid :P. There is an active listening connection on the right port according to netstat -a, and I've tried set up port forwarding / virtual server in my TP-Link modemrouter. – rFactor May 19 '11 at 15:31

You can see what applications are using what ports by running the following in command prompt

netstat -anobv

Once you find out what program is holding the port, if it is not important you can kill the process from task manager.

Something I have noticed is that minecraft will sometimes not shutdown all the way and the java program is running in the background. I have to kill the java process from task manager.

  • Thanks, but by blocking I actually meant that no one can access the port from the outside (the Internet). The port itself is available for Minecraft server, and I can connect to it locally. The server is set up listening to *:25565, and I can connect via – rFactor May 19 '11 at 15:33
  • Some things to try then: Can you run any other scripts on the server and access them externally. Such as a FTP server. Try running xampp or something and see if you can access port 80 (many isp's block this) or port 21 (ftp should be ok). Make sure your port forwarding is going to the proper ip address. If everything seems alright call your ISP and ask them if there is anything blocking the port for your account. – Ryan Matthews May 19 '11 at 15:42
  • Note that you need to run the command in an elevated command prompt – Mawg Sep 7 '15 at 7:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.