140

I'm trying to set something to gray, but can't figure out how. The only bit of info in the man page about colors I can find is:

message-bg colour
  Set status line message background colour, where colour is one of:
  black, red, green, yellow, blue, magenta, cyan, white, colour0 to
  colour255 from the 256-colour palette, or default.

I also found a blog post which iterates through colors, but I can't quite grok it, and don't want to sit at the terminal all day guessing color numbers until one works.

223

You can get a list with this bash snippet:

for i in {0..255}; do
    printf "\x1b[38;5;${i}mcolour${i}\x1b[0m\n"
done

Then use colourxxx with tmux.

  • 18
    use $ reset to get your prompt color back :> – lkraav Feb 14 '12 at 10:26
  • perhaps you need three digit colours? This script outputs like color12 but that is not accepted by tmux as a valid colour. – artfulrobot Jan 11 '13 at 11:49
  • 6
    My tmux (1.6) accepts even colors like colour12 (mind the "u"). – cYrus Jan 11 '13 at 12:28
  • 1
    This answer is still helpful! Helped me pick the colors I wanted. – asfallows Oct 18 '13 at 20:48
  • 6
    omg! A rainbow on my terminal. Just in time to celebrate marriage equality in the US! – garbelini Jun 29 '15 at 14:11
75

I found this image to be enlightening.

enter image description here

  • 16
    You can create it with for i in {0..255}; do printf "\x1b[38;5;${i}mcolor%-5i\x1b[0m" $i ; if ! (( ($i + 1 ) % 8 )); then echo ; fi ; done – 12431234123412341234123 Oct 4 '17 at 11:10
22

In Subversion (what will be tmux 1.5) you can also use #abcdef hex-style colours which are mapped to the nearest 256 colour palette entry. You need quotes as it's treated as a string, whereas regular color names are treated as named constants. Also note that 3-letter shorthand (#f00) is invalid.

Example:

set pane-active-border-bg red # no quotes for name
set pane-active-border-bg "#ff0000" # quotes for rgb
  • 1
    Can you? I can't see how to... – Eric Apr 23 '12 at 18:18
  • 5
    set-option message-bg "#abcdef"; the quotes are necessary. – chepner May 1 '12 at 20:05
  • You also seem to have to use the full 6 hex chars, no 3 char shortcuts i.e. #fff will not work, you have to use #ffffff – bschlueter Dec 9 '15 at 21:44
11

tmux through 1.9 only supports the international spelling for the 256 colour palette, e.g.

"colour121"

as opposed to the American spelling that drops the u

"color121"

Looks like this will be changed soon, http://sourceforge.net/mailarchive/message.php?msg_id=31049758

6

I've been using the xterm-color-table.vim script. Any 256 color terminal color table will work.

6

Building up on @cYrus' answer, I wrote a script to break the output of the colors into N number of columns, where N is the first argument

# colors.sh

#!/bin/bash
if [ -z $1 ]; then
    BREAK=1
else
    BREAK=$1
fi
for i in {0..255} ; do
    printf "\x1b[38;5;${i}mcolour${i} \t"
    if [ $(( i % $BREAK )) -eq $(($BREAK-1)) ] ; then
        printf "\n"
    fi
done

Try it by saving it into a file called colors.sh, then ./colors.sh 4

Don't forget to chmod +x colors.sh first.

  • 3
    Script show-256-colors.sh can be useful to show background colors as well. – Maxim Suslov Aug 2 '18 at 1:47
  • You ought to default it to say, at least 4 columns, to distinguish it from the origin script. – dbkeys Aug 26 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.