My desktop is a Vista Gateway machine with 3GB of memory. Somebody gave me a couple of 2GB memory sticks, and I replaced the old sticks (2x1GB + 2x512MB) with the new ones (used, actually). Machine recognized the new memory, but it was now working very badly. For example, Windows Explorer took up to a minute to fire up, simple things like copying folders took tens of minutes instead of tens of seconds to do. Getting a right-click context menu up took a good thirty seconds or longer. I gave up and reinstalled the original memory. Amazingly, the new bad behavior continued!

I played with the situation for awhile. Interestingly, I could play COD MW2 fine on the thing, except that every three seconds the sound would hiccup, and sometimes everything would hang for a second or two. I noticed that playing videos on YouTube was giving me the same hiccup. I tried playing a movie in the DVD player and sometimes the video would lag while the audio played on, then suddenly catch up -- and vice versa.

I resorted to reinstalling Vista from the restore disk, but when I was done I still had The same slow behavior when running Windows Explorer. To see if I had a hard disk issue, I tried running Spinrite on it, and suspiciously it only got to 57% of the disk before it seemed to hang up on me. It ran overnight and never budged off 57%, nor updated its running time! I'm tempted to just go out and buy a new hard drive, but if the problem is some other hardware that won't help. Is it an OS issue or a hardware issue?

I am out of ideas. Any suggestions are welcome!


If you reinstalled Vista fresh, I doubt that it is a software issue. From your description, you have a hardware issue. Do you have another PC to test that hard drive with? Are you back to the original memory as well? It may be coincidental, just seems a bit odd that this happened when you installed new ram. Grab a copy of the Ultimate boot cd http://www.ultimatebootcd.com/ and run all of the hardware tests against the memory hard drive, and the motherboard, perhaps it will shed more light.

| improve this answer | |
  • Yes, absolutely. After some horsing around trying to find how to download UBCD (the various links led to paid software/services rather than UBCD itself) I finally found it and used it to discover that the memory was OK, and the HDD was toasty and getting toastier -- finally Windows would try to boot but would first require CheckDisk to run. Well, the HDD was definitely the problem. Went out got a new one and have reinstalled Windows. The machine now runs faster than it ever has, so it seems. – Cyberherbalist May 20 '11 at 5:01

Mis-matching ram size and manufacturers is a very bad idea. You eliminate dual channeling when you do this, also your motherboard most likely prefers to have memory installed in a certain order [1g][512][1g][512] is the most common way (if you insist on keeping the 512).

On top of that most MB detect or have a set voltage for the ram and different manufactures will act differently. One last reason is that the latency of the RAM would theoretically be trunked down to the slowest stick. And since 512mb is pretty small... its probably older, and this would lead me to believe that it also has a high latency.

Also RAM could be bad, the other comment about ultimate boot cd is a good way to go, also I know Ubuntu has a RAM checker on most all of their bootable disk you can download.


| improve this answer | |
  • +1 for this is excellent information and I thank you for it, although it doesn't quite do it for the problem at hand. I did use the UltimateBootCD suggested by @Amartel and checked the memory with it as you suggested, and found the memory to be happy. – Cyberherbalist May 20 '11 at 4:56

Memory slots need to be used in the right order, make sure you have the memory installed into the correct pair of slots. The original memory would have been paired up as 2x1GB and 2x512MB. If you use the wrong paired slots your machine, if it runs at all, will run slowly.

| improve this answer | |
  • The memory was originally 2x1GB and 2x512MB. I'm pretty sure that's how I put it back in, but I better make sure. – Cyberherbalist May 19 '11 at 21:10
  • Yes, memory turned out to be installed correctly and in good shape. – Cyberherbalist May 20 '11 at 5:02

The most obvious answer is that the memory is bad. It may not be faulty, but it seems to be causing problems with your machine. The first thing you should do whenever you install used memory is to run a memory tester. My favorite is Memtest86.

If it test good but still performs poorly, check the documentation approved memory configurations and modules. You could be doing something outside of the spec that is causing instability.

In most cases, 3GB of memory is plenty so I don't see the point of the upgrade. Was your performance really that bad before the "upgrade"? If it was, it probably has more to do with the age of the machine than anything else.

Hope this helps

| improve this answer | |
  • Memory turned out to be OK. I did in fact use Memtest86 on the UBCD. – Cyberherbalist May 20 '11 at 5:03

Sounds like hardware, though more like a connection issue.

Shutdown, turn off the P/S, hold the case power button in a few seconds, then go & recheck all your connections. Remove & reinsert your memory chips. SATA cables to HDD & DVD ... Make sure every is connected fully & snug.

Check BIOS & make sure your drives are running in their correct "Mode", then do the same once booted into Windows. PIO (not wanted) is a possibility of you have older IDE drives.

Try with only 1 memory chip, alternating slots (though I don't think that is it).

Try with only 1 memory chip & your HDD, disconnecting all other peripherals. So no DVD, no external USB devices, no sound card if it is an addon ...

Try booting into a different User account. Try Safe Mode.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.