41

I tried opening a file of 800MB size in Notepad++. But i don't why Notepad++ showed only 269117242 chars 271450112 bytes . Neither it showed any alert message that it is unable to open such a big file. Then i used wordpad to open the same file, it worked like charm.

But why Notepad++ can't open 800MB file? I assume there must be some setting which says show only this much text.

P.S. Please don't suggest any other software which can open big files. I know they exist.

2
  • 2
    It is in general not a good idea to say something such as what you have mentioned in the postscriptum. "P.S. Please don't suggest any other software which can open big files. I know they exist."
    – bubu
    Commented Oct 1, 2013 at 11:43
  • 14
    @bubu I added this text because otherwise you would see lots of answer which will say use this xyz software to open huge files. But this was not my question. I simply wanted to know why Notepad++ can't open. Commented Oct 3, 2013 at 9:15

2 Answers 2

51

Notepad++ doesn't support huge files, according to this wiki documentation, the problem persists if the component (Scintilla) remains as the core of Notepad++ :

Older versions of Notepad++ may crash while opening very large files. Newer versions (5.2+) will deny opening the file and issue an error message. Why is that?

Notepad++ is based on a component (Scintilla) which is geared towards providing rich text viewing, with syntax highlighting and code folding, as opposed to bulk text services. There are necessary trade offs. Loading a 200MB file will require around 800MB of memory, and the OS may balk at the memory allocation request.

There are basically two ways out:

  • Split the huge file into manageable chunks, and keep only one of them in editor;
  • Use another tool which is tailored to handle massive text files.

If you still manage to open a large file, performance may not be optimal. Here is a couple things to think about:

  • Plugins which analyse and scan text will slow down NP++, disable them if possible
  • Parsing for clickable links on loading the document is slow if the document is large; disabling the clickable links has been reported to significantly help.

Another page on sourceforge also suggests that this problem persists throughout Notepad++'s life, as the community requested to solve this problem:

Why don't you try other software such as gVim? Is there any reason?

8
  • 1
    64 bit gvim at code.google.com/p/vim-win3264
    – CAD bloke
    Commented Feb 27, 2013 at 23:27
  • 3
    If Wordpad can open the file, which also allows for rich text editing, I'd say this is a bug in Scintilla. Also gVim appears to be a windowed shim around a console based editor. I would not consider it comparable to NotePad++, which is a fully functional, natively windowed editor.
    – trlkly
    Commented Jun 1, 2014 at 22:35
  • 1
    I would look into EditPad Lite. Tho even that only supports up to 2GB files. The Pro version supports larger ones. Very good. Instantly opens the big files. Commented Nov 3, 2014 at 16:08
  • @lamwaiman1988, Does the Notepad++ minimalist veresion helps?
    – Pacerier
    Commented Apr 11, 2015 at 8:01
  • @lamwaiman1988 : the gvim official ᴡindows® installer is 32 bits and doesn’t handle large files. Commented Jul 16, 2015 at 20:29
5

Syntax highlighting is one of the main sources of slow performance in Notepad++.

If you're about to open a massive HTML, PHP, etc file in Notepad++, then you should first disable the syntax highlighting for that file by going to Language > N > Normal Text.

enter image description here

You should also disable clickable links. To do that, navigate to Settings > Preferences > MISC. > Clickable Link Settings and uncheck the Enable checkbox.

enter image description here

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .