I recently switched to a Netgear WNDR3700 (v2) running DD-WRT v24-sp2 (02/19/11) std. It's basically working fine and I'm generally happy with it, but any tools that query the router via SNMP show all the interfaces as being 10 mbit. In fact, the LAN interfaces are gigabit, and the wireless interface is 54 mbit (or thereabouts).

This isn't a huge deal, except that when I try to set up alarms based on current interface use being over a certain percentage of maximum, I run into problems.

I'm unable to find anywhere in the DD-WRT interface to specify interface limits. Where does the router's SNMP service get this information? I'm able to access DD-WRT via SSH command line, so I'm wondering about the possibility of using Linux commands or configuration files to set the limits correctly. Is that even possible?

  • Have you verified that the duplexing on the port is indeed set to something other than 10mbit? The port itself may be gigabit, but if the duplexing is set otherwise, it will read as it is set. – MaQleod May 21 '11 at 3:02
  • @MaQleod: Sounds promising. Now... how would I go about doing that? – boot13 May 21 '11 at 6:01
  • dd-wrt.com/phpBB2/viewtopic.php?t=556 might help you out. It is also important to note that the duplexing to whatever the WAN on your DDWRT router is connected to needs to match. It is very likely that the router is set to auto negotiate and the other device is 10 full or half, so it is negotiating to that. If you try to force 100 or 1000 on the router and the other device actually is set to 10, then you'll get a lot of other problems with bandwidth, latency and loss between the devices. – MaQleod May 21 '11 at 21:10
  • @MaQleod: No Setup > VLANs tab in my DD-WRT interface. The page you linked to is from 2006, so maybe DD-WRT has changed a bit. I'm not convinced that the bandwidths are actually set incorrectly; I'm thinking it's more of an SNMP problem. I'm getting better than 10 Mbits on the WAN interface in speed tests. The LAN connection goes to a switch that is set to autoconfigure and shows the connection as gigabit, and yet SNMP information from the router says it's 10 mbit. – boot13 May 21 '11 at 23:31
  • Sorry, I don't use DDWRT, but I deal with duplexing and snmp issues on a daily basis, so unfortunately I can't help out much with DDWRT specifics. – MaQleod May 22 '11 at 0:29

It's most likely that net-snmp isn't detecting the interface speed correctly. You can manually configure the speed in snmpd.conf:

    interface NAME TYPE SPEED
          can  be  used to provide appropriate type and speed settings for
          interfaces where the agent fails to determine  this  information
          correctly.  TYPE is a type value as given in the IANAifType-MIB,
          and can be specified numerically or by name (assuming  this  MIB
          is loaded)

I am using solar winds free real-time bandwidth monitor, on a Linksys e4200 v1, running DD-WRT v24-sp2 (12/20/11) big(SVN revision 18024).

I can't guarantee that this will work in every circumstance, however it worked for me using the above setup, and hopefully someone else can benefit from my work.

Enable SNMP from the gui, configure it to your preference.

Telnet/SSH into your router. Do a ps and make sure snmpd is running. For example, this is what mine looks like currently: 6110 root 1784 S snmpd -c /var/snmp/snmpd.conf

Make a backup copy of snmpd.conf vi, or your editor of choice: /var/snmp/snmpd.conf (or wherever yours points to)

Here is what I appended to my snmpd.conf(This reflects a 1Gb loopback, 1Gb eth0(on this router eth0 seems to account for all 4 Gb ethernet ports), 300Mb eth1(wireless), 300Mb eth2(other wireless), vlan0 1Gb, vlan1 1Gb, vlan2 40Mb(wan), br0 1gb, and ppp0 40Mb(wan)

interface lo 24 1000000000 interface eth0 6 1000000000 interface eth1 6 300000000 interface eth2 6 300000000 interface vlan0 6 1000000000 interface vlan1 6 1000000000 interface vlan2 6 40000000 interface br0 6 1000000000 interface ppp0 23 40000000

save the file. kill snmpd, then start it with the same options as you saw above in the ps.

Please note, this may be a terrible way to do it. I don't know, I just know it worked for me. Good luck!

SNMPD.conf man page: http://www.tamos.net/guide/manpages/snmp/snmpd.conf.5.html

Here is a listing of interface types for use in the snmpd.conf. http://www.ietf.org/assignments/ianaiftype-mib/ianaiftype-mib


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.