I am having issues with phpMyAdmin on my Mac. I cannot seem to connect to the local MySQL server. When I try to log in I get the following message

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

I am now trying to find the log file. I ran phpinfo() and it tells me that the php.ini file is located in /etc, however when I look I only can see php.ini.default. I proceed to edit php.ini.default by specifying the log file to /tmp/php_errors and enable logging.

I tried to log into the MySQL server via phpMyAdmin and I still get the same error. I proceed to /tmp but the error log is not there.

Any suggestions on what I may be doing wrong?

up vote 9 down vote accepted

Try renaming php.ini.default to php.ini and edit it to enable the logging you want.

The changes probably won't take effect until Apache is restarted. Since you are using a Mac, just disable web sharing and re-enable it.

Apache's logs are located under /var/log/apache2

  • 8
    When a location isn't specified in php.ini, the PHP error log does seem to be found in /var/log/apache2/error_log by default. Thanks. – Andrew Huey Jun 7 '12 at 11:10
  • 2
    I have a custom apache install, so I found my log files with find /usr/local -name error_log . – Walrus the Cat Apr 20 '15 at 5:15

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.