I have an SD card permanently lodged in the laptop slot to serve as ReadyBoost cache. Every now and then after resuming from hibernate/sleep i notice Windows has forgotten it was even using it before. enter image description here

The old readyboost.sfcache file has to be manually deleted before telling Windows to dedicate it for ReadyBoost again. And then, it's not unusual for this laptop to recreate a new file with the old date of the last file.

Is this phenomenon correctable?


My card is formatted as exFAT (8GB). I am trying an experiment with NTFS format and observe if there is any difference.

  • When I've had this happen before, I've found that performing a disk scan / check for errors will usually resolve the error, and allow ReadyBoost to be enabled again; but then I'm not sure about the "left over" file you're reporting in my cases, so it might be a different cause. Try that anyway and see what happens (after all, there's not harm in letting Windows check that your SD card is in working order). – DMA57361 May 23 '11 at 9:26
  • The thing with the old date has to do with tunneling. – user541686 May 24 '11 at 3:00
  • Interesting explanation, Mehrdad, but i only seem to observe this tunneling happening on just this system; it also happens on a .png that i save overwrite over and over again. However, i've never witnessed this in any other system; how can i set this feature explicitly? – icelava May 24 '11 at 6:27

Try to set the hybrid sleep option as shown on this answer. This answer was answered for another question but the hybrid sleep solution might help you.

Please, let me know whether it helped, if it doesn't I can help finding another solution for your problem.

| improve this answer | |

It appears, that formatting the memory card with NTFS instead of exFAT improves the "grip" reliability Windows has on the card across system sleep cycles.

Not only does Windows remember its use of ReadyBoost, i can also observe readyboost.sfcache being updated and modified date changed per wake.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.