I am in a situation where my wallpaper is locked to a specific image on my work computer via group policy. I can't change it via the Personalization settings since it is grayed out and says it has been set by the system administrator.

Anyone know some local GPO and/or registry hackery I can do to override the domain's policy? I could probably get away with logging in under a local account for this, but I want that to be a last resort.

  • 7
    They call it "policy" for a reason. Even if you knew what registry value to change, the policy would be reapplied the next time your computer processed policy. May 23, 2011 at 13:18
  • 2
    Any changes you make to your local GPO will be over riden by the domain GPO.
    – Joe Taylor
    May 23, 2011 at 13:18
  • That said, do you know the location of the file that is used for the desktop background? Can you take the wallpaper you want and save it in that location? May 23, 2011 at 13:19
  • As @William said, its there for a reason. Even if you do mange to get into the reg and change the key, policies tend to update every half hour or so, so this will just revert it back
    – beakersoft
    May 23, 2011 at 13:24

9 Answers 9


I was able to get around by going to this location in the registry:


Inside, there's a key called Wallpaper. I deleted it and re-set the desktop background, and it worked.

You'll have to do that every time you log on though, as group policy refreshes itself. (It can also be set to refresh automatically.)

  • 2
    I wonder if you could change the permissions on the key itself to your account being the only one with write permissions. I know this works for disabling UAC when enforced by GPO. May 26, 2015 at 3:44
  • This helped me. I had to delete both Wallpaper and Wallpaper Style keys to reset the desktop background. Thanks.
    – digitguy
    Sep 11, 2015 at 15:10
  • Create a .reg file that removes the Wallpaper key. In your Start Menu's Startup folder create a shortcut to regedit that uses the /s swtich to merge the .reg file into the registry. Viola. Pesky reg key removed each time on login. So far this seems to be working for me. YMMV as my login does have admin rights to this pc.
    – ensignr
    Apr 4, 2017 at 7:12
  • 4
    @music2myear Anyone who would fire you because you don't want to look at a (just to pick a random example) blinding white desktop background every day of your life wouldn't be worth working for in the first place. There's no excuse for that crap. Jul 28, 2017 at 21:22
  • 2
    To me, the best solution to both music2myear and Joel concerns is to force a black background for all workstations and block wallpaper websites. Then no one complains and focuses on work instead, like they should. Feb 1, 2018 at 15:48

Even if there were a hack, GPO is rechecked and reset regularly and each time you log in.

I assume this policy was probably created as an over-reaction to potentially offensive desktop background images.

Petitioning your IT org to change this setting and simply rely on people making the right choice or getting talked to by their managers may be a more effective solution.

  • 1
    Great points but this is more or less an issue because system admins like to play jokes (like setting people's wallpaper to hello kitty). I'll simply just use a local account :) May 23, 2011 at 14:42
  • 2
    Ahh, those mischievous sysadmins. They are so very clever. Can't say I've never done that, but it could result in an anonymous complaint to a corporate anti-bullying line... May 23, 2011 at 14:45

Easy...just do a search for the name of the wallpaper. Once you find the location that has the filename (i.e. wallpaper.jpg), simply rename that file to wallpaper-Old.jpg (or something like that). Next place either the image, or a link to an image, that you want to use in that location with the name wallpaper.jpg ( or whatever the original file's name was). This is just continuing with what W. Jackson was hinting at...

That said, do you know the location of the file that is used for the desktop background? Can you take the wallpaper you want and save it in that location? – William Jackson

This is just a workaround that does not require hacking the registry or any of the sysadmins' settings from A/D or the local machine.

  • TNO! This thread is a perfect example showing why users are the greatest security risk to protected resources and end up costing business billions a year...the admin's job continues to go unappreciated!
    – argentwolf
    May 21, 2013 at 11:43
  • 17
    Yeah, changing a jpg is a huge security risk. If even 1 user replaces a simple jpg the entire domain is under attack and at risk of causing mass destruction on a level you've never seen before.
    – Nick
    Nov 20, 2014 at 16:06
  • @Nick Yes, that's entirely possible if the user provides a malicious image with an embedded exploit for some 0-day in Windows, we saw many of those in the last years, and the payload is some stuff like WannaCry, which you could read about in the media in the last month. But as a security pro, you of course did know all that... Jun 8, 2017 at 13:12
  • Why are you replying to 3 year old comments?
    – Nick
    Jun 13, 2017 at 14:37

A slight variation to Ryan's answer above is to load regedit and to navigate to the same key:


Under this key there may be a key:


If there is a string called "NoChangingWallPaper" set it to = "0"

Under the key:


If there are strings "Wallpaper" and "WallpaperStyle" then delete these two strings.

Close regedit and then go into the "Personalize" settings and you should be able to change the wallpaper to one of your choosing.

If this still doesn't work you may need to log out of Windows and log back in.

The above was tested successfully on Windows 10.

I also find that the Group Policy synchronisation is usually less frequent than daily (but I guess each environment could differ here). Logging onto your PC before connecting to the network can help reduce the frequency of the Group Policy re-sync as well. If you have a laptop and it supports hibernation this can also decrease the frequency of Group Policy re-sync. I can usually go at least a couple of weeks to a month without the group policy wallpaper being re-applied and this is without implementing any automation scripts on startup.


Here is a workaround if you are the local admin on your machine:

...and if you can find the image that the policy is using to set your wallpaper (in my case it was in C:\Windows\Web\wallpaper\backround.jpeg) you can change it's security permissions to deny all.

Next time you log in, the policy will not be able to overwrite the image or set it as wallpaper and hence it will default to a solid colour background. In my case I am still not able to choose a new image for the background because group policy disabled that option; I am however able to choose the Windows 7 default theme which set the background to default black.

I only wanted a black background in my case so I did not try to tinker around with the various read/write/modify permissions on the image itself. However, theoretically, you may be able to make your own image, name it the same as the default group policy background image, replace the default image with the new, change permissions on all groups, users to read only. This way the policy should fail to overwrite the image but succeed to set it as the default background. I have not tried this last bit.

This is the only solution I know off that is not temporary. All other solutions, including those that change the registry settings, will be overwritten by the policy every time you log in.

I tried using DisplayFusion and it does work but the change is temporary to the current session; DisplayFusion software will change the wallpaper to any of your chosing but every time you log out and back in and policy is re-applied, you will have to open DisplayFusion and hit OK to update the wallpaper.


firefox definitely over rides the policy key. My system is locked down like fort knox i cant do anything through registry key nor through local policy everything is locked but using firefox right-click and then setting image as desktop background worked like a charm.

  • I couldn't delete the reg key, but this worked for some reason. If the wallpaper keeps getting changed back after reboots, just save the image you want to use as a wallpaper somewhere in your computer, then open the image file in the browser and save it as a bookmark. Now every time you want to change your wallpaper, open the bookmark and set it as a wallpaper.
    – Naucle
    Jul 9, 2018 at 11:00

Open the image/wallpaper in your browser (IE). From there right click on the image and select set as wallpaper.

Problem is however when you log off/shut down it will revert back to the group policy set up. But you can just do the above again once you login.

  • Why the "(IE)" in your answer? What if you don't use that browser? Jun 16, 2016 at 10:47

Apparently, Firefox is able to override the policy and can set the wallpaper. just right-click on the image and click "set as desktop background."

  • This doesn't work. The policy is re-applied on the next reboot.
    – DavidPostill
    Dec 16, 2016 at 10:42

Save this as a .reg file and place a shorcut to it in your startup directory.

Windows Registry Editor Version 5.00

  • Where does it mention placing a registry file in the Startup directory? Feb 1, 2018 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .