I've been looking into this problem on one of my client networks for a couple of weeks now, trying different things.

I found this post on Microsoft Technet from a guy having exactly the same problem, So I thought I'd try reposting it here to see if I get any positive response. If any of you can help me I'll pass the answer on to Randy on Technet and give credit where it's due with a link, unless there are objections to that!

I have tried everything I could find by searching but the searches are now either repeating themselves or saturated with unrelated solutions so I figured I should just ask.

My domain is running windows 2k8 R2 print server.

Clients are Dell Latitudes E6410/6510, sony viaos, and toshiba proteges pushing Windows 7 pro 64bit with office 2k7 pro, adobe 8pro and networked printers (Ricoh, HP)

The problem: Print spooler will not be working after a computer start/restart or after a computer is disconnected from the domain. restarting the print spooler service will usually fix it and the machine will work fine for the rest of the day or until it is restarted. I get NO ERROR MSG stating that print spooler crashed after bootup. When I check the services it shows that print spooler is started and that there are no problems with it but when you try to open printers or word they will both hang. restarting print spooler is the only way to fix it.

What I already tried: different drivers, re-installing office, re-installing adobe 8 pro, replacing normal.dot, clearing printer temps/folders, registry fixes and system scans. I even went as far as taking a laptop, doing a clean format/install with win7pro 64bit, doing all of the windows/office/adobe update after installing office 2k7 pro, adobe and the printers and it still crashes the exact same way. Also tried the following and a couple more and none of the worked:

Scenario 1: computer starts, staff attempts to open word and word will hang. I will then force close word, check printers and sure enough the printers aren't showing. So I restart the printer spooler service and everything starts working back up.

  • So you're having the exact same problem, but have you tried the exact same steps to resolve it (as outlined in the post you quote)? – slhck May 24 '11 at 10:36

Have you used the Clean Spool app in the Server Resource Kit? I know it is in the 2003 resource kit, not sure if it is in the 2008 RK.

I've had issues like this in the office and it appeared to be caused by a printer driver that failed to install properly (HP Univeral Printer Driver). I reinstalled the driver on the server, and then ran Clean Spool on each system that was having the stability/app crash issues. This resolved the issue for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.