How can I reset the open file window in Google Chrome back to it's default size?

My wife resized it when uploading photo's to a website and I would like to reset it

I have deleted the BagMRU & Bags registry keys, but they do not appear to affect Chrome

I have also deleted my user profile and started Chrome from scratch but that does not make any difference either

Thank you

  • If you re-size the window and click the red x button instead of opening a file it should save it's state. – Justin Pearce May 24 '11 at 19:08
  • Too late for that I'm afraid :( – vassie May 24 '11 at 22:06
  • @Ben, Justin was actually talking about the close-button of Chrome, which wouldn’t affect the File Dialog anyway. – Synetech May 25 '11 at 17:45
  • Where were the Bag keys you deleted (which key)? – Synetech May 25 '11 at 17:57
  • I followed this superuser.com/questions/3347/… – vassie May 25 '11 at 19:53

First make sure you close the Chrome application (since it still running and writing- and overwriting your changes- to the "Local State" file even though you can't see the maximized Chrome window).

Next, find the file c:\Users{UserNameHere}\AppData\Local\Google\Chrome\User Data\Local State and delete (or rename) the whole the file and restart Chrome.

All your previously opened tabs will be present and the default page position/size will be restored.

| improve this answer | |
  • Generic alternative to path provided: %localappdata%\Google\Chrome\User Data\Local State – Tim Friesen Mar 21 '19 at 12:20

No, Chrome isn’t a normal window, so ShellBags has no effect on it. Instead, Chrome handles its own window-positioning (well, normally, when it works; sometimes it gets stuck or reset/forgets).

First, close all Chrome windows (and make sure that there are no CHROME.EXE instances running in Task Manager). Open your Chrome profile (the User Data folder) and look for the Local State file. Open it in a text-editor and look for the window_placement section inside the browser section and delete that—this is a structured file, so make sure to get the quotes and braces correctly. (There are other window_placement sections for other things like the Options dialog, Task Manager, etc.) Finally, save and open Chrome; it should open at a “default” location, but should remember where you set it when you subsequently close it.

| improve this answer | |
  • I have closed Chrome and looked in the Local State file, but there is no mention of window_placement at all – vassie May 24 '11 at 21:48
  • That’s strange. Is there a line as follows? "browser": { Try searching for work_area_bottom (though there could be several of these). – Synetech May 24 '11 at 21:55
  • All I have in the browser section is: { "browser": { "hung_plugin_detect_freq": 2000, "last_known_google_url": "http://www.google.co.uk/", "last_prompted_google_url": "http://www.google.co.uk/", "last_redirect_origin": "", "plugin_message_response_timeout": 30000 }, – vassie May 24 '11 at 22:00
  • 1
    I found them under AppData\Local\Google\Chrome\User Data\Default\Preferences removing them resets the Chrome window size and location, however I want to reset the open file dialogue window, ie Ctrl+O, also the same window when you browse for a file you wish to attach to an email in Gmail – vassie May 24 '11 at 22:04
  • 1
    Only Chrome, everything else is fine – vassie May 25 '11 at 19:53

I couldn't figure this out either, but somewhere I had messed up a setting. Performing a system restore seemed to solve the problem.

| improve this answer | |

To permanently set the Chrome window size and position add the following switches to the shortcut that opens Chrome. You can adjust the path and numbers to suit your own situation.

"C:\Program Files\Google\Chrome\Application\chrome.exe" --window-position=200,50 --window-size=1400,900

To apply these switches, right click the Chrome shortcut and choose "properties". Add the switches to the target textbox. Start each switch with a space followed by -- and then the a switch as shown above. A second switch can be added by leaving a space and then writing the next one. The switches used here are

Don't leave any spaces within the switch. Always start a switch with a space and then -- Place the switches outside the path quotes ("").

| improve this answer | |
  • Sorry I can't vote twice : ) – Nime Cloud Nov 23 '16 at 12:28

Default window opening size is a widows thing. Just need to set the size you would like it to open, hold down Ctl and close the window, next time you open it, it will be that size and position.

| improve this answer | |

What worked super simple for me. I just right clicked on the close red X and then hit restore. And that worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.