I'm having a problem with Thunderbird and I can't for the life of me figure out what the problem is.

I'm using
OS X 10.6.7
Thunderbird 3.1.10

I have it configured to check 3 IMAP Google accounts, one of which sees massive amounts of traffic (the account I use for mailing lists). I mention the high traffic volume because I suspect it is closely related to the problem.

The problem is this: Thunderbird regularly and without warning locks up, pinning one of my CPUs and going completely unresponsive for a period of anywhere between 5-45 seconds.

I've found that the best way to reproduce this bug is first configure 3 mail accounts, one with around 1.9 gigs of emails (no attachments, just regular emails), then simply click Write to open a new email dialogue. Within 10 seconds, Thunderbird (and the new Write window) locks up becoming unresponsive. You can continue to type as you normally would but characters are just held in the buffer until Thunderbird comes back, at which point it catches up on everything you typed.

I've tried checking the Activity Monitor while writing a new email to see if anything shows up, but nothing does. The only way I know how to get it to not lockup like that is to disconnect from the internet while I'm composing the email. But that's really only a temporary fix that really only applies to writing emails, and this lockup problem rears it's ugly head even when I'm browsing my email in my inbox.

I switched from Apple Mail to Thunderbird for the OpenPGP plugin, something Apple Mail still doesn't support natively to the best of my knowledge, so I can't switch back. I remember Apple Mail didn't have this problem though, so I'm considering using Apple Mail for anything not requiring signing/encrypting, but I'd really like to figure out and fix what Thunderbird is choking on. It's Open Source, after all.


I too have had this issue intermittently for the last couple months with large imap folders. I have tried everything recommended - from latest TB versions, removing msf files, removing attachments of all historical messages, compacting on a regular basis, global indexing on, global indexing off, anti-virus set to not scan TB or email folders, and more. Recently found a post by another that recommended making sure all device drivers are the latest. I had a NIC driver that was a couple years old - updated to new that was released this past March. So far so good, no more lockups/freezing. I will continue to monitor to confirm if this is what ultimately resolves the issue. Hope this helps.

  • From your mention of driver-fiddling I presume your using Windows? I'm on a Mac but hopefully any other Windows users encountering this problem can resolve it with your fix, Thanks :) – Jeff Welling May 31 '11 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.