When I'm using the English language in MS-Word 2007, it does indeed use a new dictionary, but the automatic caption names are still in my own language (Dutch).

For example: If I use insert caption I see Figuur 1 instead of Figure 1.

How can I configure the captions to use the same language as the base language of the spelling checker?


MS-Word itself is supposed to use the "Regional" settings of Windows. You can change this setting for Windows here: Control Panel -> Regional and Language

enter image description here

enter image description here

If you don't already have any other languages installed (just as I don't on this particular computer, as pictured above), then you'll need to add one, otherwise there should be a list of language choices there for which you can set the default for Windows.

  • 1
    Too bad it can't set itself in Word... – Marnix May 25 '11 at 20:16
  • @Marnix: +1 for an idea that may be useful to some people. There are certain things that should be handled by the Operating System's GUI, such as theme and colour scheme, global language, timezone, etc., and if this can be set separately for each application it could lead to a very confusing environment for people. At least these settings can be customized on a per-user basis (hint: you could set up a separate user account for other languages if you regularly need to use different languages and would rather not keep switching the default language through regional configuration settings). – Randolf Richardson May 25 '11 at 20:20
  • 1
    I have been looking, and I see that you have the same problem: There is nu button that says: install extra language. But this movie says there should be one: windows.microsoft.com/en-US/windows7/… – Marnix May 25 '11 at 20:23
  • 1
    @Marnix: I recommend that you start a new question for that one since it's about adding a language to Windows 7 (this question was about regional settings in MS-Word). I suggest you include these tags in the new question: regional-settings windows-7 – Randolf Richardson May 25 '11 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.