49

Whenever I compose a new email message in Thunderbird, it defaults to the Western (ISO-8859-1) encoding, and I have to manually change it to UTF-8 every time.

How do I change the default?

5 Answers 5

2

In Thunderbird 78+:

Menu > Options > General > Language & Appearance > Advanced button > Text encoding

Text encoding settings in Thunderbird 78

3
  • Thank you for the updated answer that applies to more recent versions of Thunderbird! :)
    – hpy
    Apr 7, 2021 at 1:14
  • Don't you just love how it seems to change in every... single... version... ? ;p Apr 8, 2021 at 0:48
  • This (the whole contents of the red frame) seems to be gone in TB 91+ - any idea if it still is customizable? Apr 26 at 11:08
55

Tools → Options → Display → Formatting → Fonts → Advanced... → Character Encodings → Outgoing Mail:

Screenshot

4
  • 5
    Well, that is somewhat illogical to put it there … Thanks! Mar 31, 2012 at 20:22
  • 6
    In linux it's Edit > Preferences > Display... Feb 2, 2013 at 3:20
  • 3
    Agreed that it's illogical : you'd expect it to be in "Composition", not "Display". Completely defeats principle of least surprise. They could at least adopt a prefs dialog like Eclipse that will filter to aid discovery of obtuse settings.
    – Adrian
    Dec 1, 2014 at 15:40
  • Display... on THEIR machine!
    – Worthy7
    Apr 13, 2017 at 4:19
13

For Thunderbird 17 on the Mac, you can find this setting at:

Thunderbird > Preferences > Display > Formatting > Advanced

Look at the Character Encodings section, as seen here:

enter image description here

2
  • Regarding your comment; I did test it and it is the very same path, only with Edit except Thunderbird under Icedove@Debian and the dialog also looks the same (except for the theme, obviously).
    – bitmask
    Jun 27, 2013 at 5:32
  • Great. Add a new answer with screenshot. Jun 27, 2013 at 12:32
5

On Mac OS X you have to use the Config Editor (also know as about:config) found in Preferences -> Advanced -> General. Change the value of the preference named mailnews.send_default_charset to UTF-8.

0

On Thunderbird 68:

Edit>
    Preferences>
        Display>
            Formatting>
                Font & Colors>
                    Advanced (button) > 
                        Text encodings      
2
  • Thunderbird, not Firefox. Are the menus the same?
    – Karu
    Jan 8, 2021 at 18:54
  • Sorry I meant Thunderbird.
    – xenoid
    Jan 8, 2021 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.