2

One of my users had a network error and when she opened Outlook it made a new .pst file for her. The normal one is on a network share which which was easy to fix but now she cannot search emails before the date we re-added the .pst file. Emails received afterwards show up correctly but emails that do exist yet were delivered before the date of the error cannot be searched.

Is there any way to tell Outlook to re-index the .pst so she can search older emails again?

Outlook 2007 running on Windows 7.

2

Another solution is to use a tool outside MS universe. A tool called DocFetcher can index .PST files and has even proximity search.

http://docfetcher.sourceforge.net/en/index.html

Indexing 0.8GB file took about 7 minutes and the searchers give correct results. It has Lucene as the search engine beneath.

  • Nice. I fought for a long time with getting windows index to work. I'd fix it one month and it would 'break' in a different way the next month. This seems like a good alternative. – VoteCoffee Sep 27 '17 at 13:24
  • Also really good for my orphaned email boxes that I keep for archival purposes but don't access via outlook – VoteCoffee Sep 27 '17 at 13:24
0

Yes, there is a way to force the reindexing of .pst files.

Just run Scanpst.exe on the .pst file (you'll need to close Outlook and any other program accessing the .pst file at that time.

The Scanpst.exe file for Outlook 2013 is located in the following folder: \Program Files\Microsoft Office 15\root\office15

The Scanpst.exe file for Outlook 2010 is typically located in one of the following folders: \Program Files\Microsoft Office\Office14 or \Program Files\Microsoft Office(x86)\Office14

The Scanpst.exe file for Outlook 2007 is typically located in one of the following folders: \Program Files\Microsoft Office\Office12 or \Program Files(x86)\Microsoft Office\Office12

Source: http://support.microsoft.com/kb/272227/en-us

0

I had an issue where the properties of the pst file did not allow indexing of contents. If you right click on the pst file, press the Advanced button under the General Tab, the Advanced Attributes window pops up. "Allow this file to have contents indexed in addition to file properties" needs to be checked. somehow mine had gotten unchecked and this caused the emails it contained to not show up in search results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.