Not sure if I should post my question in superuser, but it looks like the most appropriate place among all StackExchange sites.

I have a 16GB Kingston DataTraveler USB drive. When I tried to use it this morning, it showed up nothing in there but yet its details showed that half of the capacity was in used. I tried it with OS X, Ubuntu, and Windows 7 and the results were the same. I tried to create a new folder and it worked. Apparently, the drive is working but somehow not showing my previously stored data. Note that I was still using the drive last night and there wasn't any problems.

Following @rob's suggestion, du -h gave me:

./.Trashes 960K 
./.Spotlight-V100/Store-V1/Stores/2620683B-A38B-42F4-A247-45CAF4826ADE 976K ./.Spotlight-V100/Store-V1/Stores 1008K 
./.Spotlight-V100/Store-V1 1.0M 
./.Spotlight-V100 1.1M

And, df -h gave me:

/dev/sdb1 15G 7.9G 7.1G 53% /media/KINGSTON 

Confirming what I reported.

Anyone got a clue/answer to this issue? Thanks.

  • 1
    New drive? Existing drive? Purchased on Ebay? Stuff like this is a possibility, "CAVEAT EMPTOR, BEWARE of Counterfeit USB Flash Drives" reviews.ebay.com/… – therube May 26 '11 at 19:37
  • I have been using it for about an year. I bought it from a well known local retail. I don't think it's counterfeit. I have just submitted a ticket to Kingston. – tamakisquare May 26 '11 at 20:05

Did the files/folders get marked as hidden, or are they simply unreadable to the user accounts you're using?

On Linux, open the terminal and login as root or run sudo bash. Then cd to the USB drive (usually a subdirectory in /media/), and run the command ls -a. From that directory, also try du -h to see the sizes of the files/directories on the drive. You can also compare this to the output of df -h, which reports filesystem usage.

If you still can't see the files as root (i.e., if the number returned by du -hs isn't about the same as that from df -h), the filesystem on your USB drive is probably corrupted somehow. You can try a file recovery tool like PhotoRec or Recuva (both free programs).

In the past, I've also used RecoverMyFiles ($70) with good results. Most commercial data recovery software will let you scan a drive for free to see if any data is recoverable, then you buy a license key to activate the recovery feature.

Just be sure to restore the files onto a different drive or filesystem (like a folder on your desktop), otherwise you risk overwriting some of the data that you're trying to recover.

  • @ahmoo, if that's all you got from du -h as root, then it sounds like your filesystem has been corrupted. I've added a few free and paid file recovery tools to my post above; you could also try the program that Nixphoe recommended (GetDataBack). – rob May 27 '11 at 0:34
  • @KeithB Good point. Thanks for the suggestion. – tamakisquare May 27 '11 at 0:58

A few things to check

  1. Check if there are any hidden files on the usb drive.
  2. You could also use Disk Management to see if there's any issues with the partitions.
  3. You might also try using a program to recover lost data like get data back.
  4. The last thing I could see causing something like this is flash drives are known for stuff like this. A little bit of static, ie your pocket, could wipe a drive. Doesn't happen very often, but I've seen it.

the following should work:

  1. Go to "Tools" and click "Folder Option"
  2. Choose the View tab
  3. Uncheck the "hide protected operating system files (Recomended)"
  4. Then click Ok, and then your through.

I think the virus did something weird on your folders. It converted them into system files, so the computer will recognize them as system files. Due to your default setting of hiding all protected operating system files they are hidden.

  • OP never mentioned or confirmed having had a virus. – DavidPostill Sep 13 '14 at 17:29

First, plug in your USB memory and then follow the steps below

  1. Select Start > Run
  2. Enter cmd and press Return to open Terminal
  3. Paste and run the following command (replace the a: with your actual USB drive letter!)

    attrib -h -r -s /s /d a:\*.* 

Then wait for a minute and open your USB memory in Explorer. It should show all your files and folders.


Are you sure it's not partitioned? Try opening examining the drive with a partition editor. Note; Windows will ingore all but the very first partition on a flash drive.

  • Nope, I just checked. It has only one partition, the primary one. – tamakisquare May 26 '11 at 20:26

A few minutes ago I had the same problem, but I'm using Windows. 4 GB flash drive, I had about 1 GB of data, then while opening it seemed to be empty, but in properties it had 1 GB of occupied space.

What I did:

  • I use ESET NOD32 Antivirus 5 and I went to Custom Scan

  • It showed me a full structure of the drive. Somehow I had another drive on it:

  • When I opened it it had all of my files. The access to it was by copying the path (on my screenshot it's H:/ /) but the space between // was not a space you write on spacebar, I tried many times, 1,2,3,4 spaces.

  • I copied the path from Eset. Then my data appierd and I just copied it back to H:/


Go to "Tools" and click "Folder Option" Choose the View tab Uncheck the "hide protected operating system files (Recomended)" Then click Ok

Now You can see those files, Just delete and redo the unchecking process.


Simply "search" for one of the files you know the name for. Then open "file location" You should be able to find the files wherever they are

Not the answer you're looking for? Browse other questions tagged or ask your own question.