I'm probably missing something obvious, but I have huge trouble watching .3gp videos (taken with my Android phone) or .mov videos (my friends send me from their iOS devices) on Linux. I'm running OpenSUSE 11.3.

Take for example this .mov file a friend sent me:

[nathanb@nathanb-box ~/tmp] ffmpeg -i IMG_0543.MOV                                                                                
FFmpeg version SVN-r201104161305, Copyright (c) 2000-2011 the FFmpeg developers                                                   
  built on Apr 16 2011 11:36:21 with gcc 4.4.1 [gcc-4_4-branch revision 150839]                                                   
  configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-postproc --enable-gpl --enable-x11grab --extra-cflags='-fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm' --enable-debug --disable-stripping --enable-libgsm --enable-libschroedinger --enable-libdirac --enable-avfilter --enable-libvpx --enable-version3 --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libdc1394 --enable-pthreads --enable-librtmp                                                                                                        
  libavutil    50. 40. 1 / 50. 40. 1                                                                                                                         
  libavcodec   52.119. 1 / 52.119. 1
  libavformat  52.108. 0 / 52.108. 0
  libavdevice  52.  4. 0 / 52.  4. 0
  libavfilter   1. 79. 0 /  1. 79. 0
  libswscale    0. 13. 0 /  0. 13. 0
  libpostproc  51.  2. 0 / 51.  2. 0

Seems stream 1 codec frame rate differs from container frame rate: 1200.00 (1200/1) -> 30.00 (30/1)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'IMG_0543.MOV':
    major_brand     : qt
    minor_version   : 0
    compatible_brands: qt
    creation_time   : 2011-05-26 19:38:43
    encoder         : 4.2.1
    encoder-eng     : 4.2.1
    date            : 2011-05-26T15:36:19-0400
    date-eng        : 2011-05-26T15:36:19-0400
  Duration: 00:00:06.33, start: 0.000000, bitrate: 804 kb/s
    Stream #0.0(und): Audio: aac, 44100 Hz, mono, s16, 63 kb/s
      creation_time   : 2011-05-26 19:38:43
    Stream #0.1(und): Video: h264 (Baseline), yuv420p, 480x272, 734 kb/s, 30 fps, 30 tbr, 600 tbn, 1200 tbc
      creation_time   : 2011-05-26 19:38:43
At least one output file must be specified

If I try to play it in vlc, I get

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

I've tried using ffmpeg and mencoder to transcode into something I can watch, but everything I've tried completely failed. Am I doing something dumb? I thought VLC was able to play pretty much anything and everything.

Examples of stuff I tried:

ffmpeg -i IMG_0543.MOV -acodec copy -vcodec libx264 out.avi
ffmpeg -i IMG_0543.MOV -acodec copy -vcodec libxvid out.avi
ffmpeg -i IMG_0543.MOV -acodec libmp3lame -vcodec libxvid out.avi
mencoder IMG_0543.MOV -ovc lavc -oac mp3lame -o out.avi

None of these produced a file I could play with vlc or mplayer.

I'm probably just doing something dumb. Any ideas as to what?

  • 1
    Yes, VLC shouldn't have any issues playing 3gp. If you open one with Mplayer, does it ask if you would like to download the appropriate codec?
    – Blomkvist
    May 26 '11 at 20:44
  • Hmm...I think gmplayer is doing something dumb. If I pass -vo x11 to it, it will display the video. It's probably badly configured.
    – Nathan
    May 26 '11 at 21:16

Make sure that you have installed the codecs/packages from packman (and not from the official repositories).

Mplayer, libxine, vlc and gstreamer from packman should have no trouble playing these formats.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.