7

I have two monitors connected to my computer. (same graphics card. One HDMI, the other DVI).

Whenever I do one of the following things, my icons move around on my desktop:

  1. Play a Game
  2. Turn off one monitor

When I stop playing the game or turn one of the monitors back on, Windows 7 does not properly restore the icon locations.

Is there is a way I can prevent Windows from moving my desktop icons around?

  • Can you connect the HDMI monitor to a VGA or another DVI port? – Vladislav Zorov May 31 '11 at 16:07
  • No. :( only two ports on my video card: DVI and HDMI. – ray023 May 31 '11 at 16:14
  • Oh.. sorry to hear that. It doesn't work correctly if Windows thinks it's a TV, otherwise with two normal monitors it's working correctly. – Vladislav Zorov May 31 '11 at 16:16
4

I found something that works for me and hopefully it will work for others too.

  1. Without your monitors plugged in, right-click on your desktop, hover over "View" and turn off the feature "Align icons to grid"
  2. Plug in your monitor and proceed only if your icons remain in their original positions
  3. Turn "Align icons to grid" back on the same way you turned it off.

Using the steps above, this should allow you to unplug/turn-off monitors and replug/turn-on monitors without your icons moving all over the place.

I noticed with this, however, that it's save-file-like and you will need to redo the steps if you want to move icons around. I tested this by unplugging my monitor, moving an icon (without changing the grid feature) and plugging my monitor back in. I observed that the icon returned to its original position on my desktop as it was before I moved it and the rest of my icons stayed in the same spot. I then unplugged my monitor and found that icon to move to where I originally moved it to, so I turned the grid feature off, plugged in my monitor and then turned the grid feature back on and found the icon to stay in its new position.

I don't know how well this will work for your games (worst off you just need to leave the grid feature off) but it will hopefully solve turning monitors on and off.

3

No. When the screen resolution changes, Explorer will automatically move icons that would otherwise be off-screen.

(Imagine the complaints if it didn't do that. "I changed my monitor and now half my files are gone!")

2

I figured out one way to handle this. I have an application I use (fences) which allows me to group all my icons. I already had most of my desktop icons grouped with this application and noticed that they restore properly. So, I just created a "Miscellaneous" group and threw all my stray icons in there. I don't like this solution, but it's the best one I can come up with since windows will not properly restore icons or allow me to turn that "feature" off. :P

2

Icons move when the desktop resolution changes. This can be caused by any full screen application such as games, or by the addition / removal of multiple monitors. The fix is easy, permanent, and requires no additional software. Right-click on the desktop and select "Personalize". Then select "Themes", then "Desktop icon settings", and UN-check .. "Allow themes to change desktop icons", Apply. You may need to move some icons at the bottom of your screen so they are visible on the lower resolution setups, as windows will no longer do this for you.

1

I know of three utilities to address this problem. Not all work on all versions of Windows. The three are:

Iconoid - a useful tool to save & restore desktop icon positions and with more features. It is available free from http://www.sillysot.com/ For your described problem, this is the most likely direct solution

Fences - This is my current solution. It is well-maintained and runs on all versions of Windows. Use it to organize your icons as you wish within groups and Fences will see that they stay put. Unfortunately they do not currently maintain the position of ungrouped icons (I've already put in a request for that feature). This is a retail solution, but not too expensive. It has many additional features that I have found useful, too.

WinTidy - a PC Magazine utility that I used for many years. Unfortunately, they seem to have discontinued support of their utility library and it seems to be difficult or impossible to buy. But you may be able to find it from a 3rd-party source. It memorizes the positions of icons for various screen resolutions and restores them automatically or on demand.

1

In Run > Regedit... Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

Then create Key Explorer.

Add new DWORD value NoSaveSettings and set to 0.

Restart Computer... All Fixed

0

I came here looking for a solution but it seems there isn't any and what has been suggested are still workarounds.

Look up: "monitor detect killer".
Its a cheap and cleaver hardware solution.
Good luck.

  • 1
    Welcome to superuser: While this may or may not answer the question,(an answer has been accepted) it would be a better answer if you did not name a pay for software program (try software reconmendations in all stackexchange sites - this could lead to your answer being viewed as spam). Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Mar 28 '18 at 6:47
0

With your primary screen active (do not project to monitor yet),

  1. Arrange your icons the way you'd like them to be when you have primary monitor(laptop) active only.
  2. Extend screens, you should see no change in your arrangement.
  3. Drag arrangement to new monitor.
  4. Go back to primary monitor only, you should see that the arrangement was the same as you had originally set up on your primary screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.