My current time in Windows7 is set to UTC +8 (Kuala Lumper). For some reason, the time is always 8 hours ahead. Curiously though, my applications seem to be using the 'right time' that is it is not 8 hours ahead. For example, the local time now is 12pm, windows time is reporting 8pm. If I send an email to myself via outlook, the time shown is 12pm. So only the windows time is off kilter.

I can fix this by syncing the time with the Internet Time Servers but it jumps back to the wrong time every few hours.

I have been having this problem since I dual booted my win7 with linux ubuntu if it helps.


By default, Windows assumes your hardware clock is set to your local time, while Ubuntu assumes your hardware clock is set to Coordinated Universal Time (UTC).

You can either configure Windows to use UTC, or configure Ubuntu to use your local time, as Ubuntu's documentation explains:

Make Windows use UTC

Note: This method was not initially supported on Windows Vista and Server 2008, but came back with Vista SP2, Windows 7 and Server 2008 R2.

To make MS Windows calculate the time from the hardware clock as UTC. Create a file named WindowsTimeFixUTC.reg with the following contents and then double click on it to merge the contents with the registry:

Windows Registry Editor Version 5.00


Make Linux use 'Local' time

To tell your Ubuntu system that the hardware clock is set to 'local' time:

  1. edit /etc/default/rcS
  2. add or change the following section
# Set UTC=yes if your hardware clock is set to UTC (GMT)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.