No, the four-second hold on the power button isn't working.

The battery is built-in and not user removable.

I was working on installing Fedora 15 on a new Samsung 900X3A (a very neat machine) and Linux crashed while trying to reboot. After that, nothing works. The power button does not work. Closing the lid does not work. Control-Alt-Delete does not work.

I am currently working on the plan of letting the battery run dry and then rebooting it, but I would welcome anything that let me get back to using it earlier.

  • I'm having the exact same issue right now. Apparently I have to wait until it runs out of battery. :(
    – passy
    Commented Jun 4, 2011 at 14:35
  • 2
    By the way I found out why this happens or at least a theory that holds up in testing. Apparently the power button is handled by the same hardware that handles the keyboard and the LEDs. When the kernel panics and blinks the caps-lock LED this constantly resets the timer for how long the power button has been held down. Therefore the keyboard controller never resets the power.
    – Zan Lynx
    Commented Jul 6, 2011 at 20:17
  • To avoid having the kernel blink the LEDs you can put i8042.dumbkbd on the kernel command line.
    – Zan Lynx
    Commented Jul 6, 2011 at 20:18
  • Same issue with a Samsung Series 7 Chronos. Putting i8042.dumbkbd doesn't prevent the kernel to blink the led when going into panic mode (but I lost caps lock led in normal use). Commented Mar 28, 2016 at 13:33

4 Answers 4


According to this blog post the Samsung tech support confirmed that there is no way to force a reboot if the device is completely locked up. He ended up tearing it apart and unplugging the battery cable.

Kernel panic isn’t typically a huge problem, except in this case: when the system went into Kernel panic, the hard-reset itself no longer worked! I called Samsung tech support to see if a hard-reset called for anything more than holding down the power button until the system turned off, but it did not. The system was simply too deeply locked up to even be reset.

Given the machine’s seven-hour battery life, I didn’t feel like waiting out the problem, so I ultimately ended up taking apart the hardware to yank the battery cable.


There actually is a way of enforcing a power-off. On the bottom of the laptop there is a tiny pinhole. If you put a paper clip in it while it is unplugged, it will turn off. However, it will refuse to boot until it is plugged in again!

Orientation help

  • Confirmed the pinhole thing on the 900X3A. It wouldn't start up until about 10 seconds after stopping it.
    – l0b0
    Commented May 3, 2013 at 16:52
  • works on the Qx411 too, pinhole is right in the middle of the bottom.
    – Ian B.
    Commented Jun 7, 2014 at 1:03

In addition to what has been said already. As you're using Linux you might be able to use magic sysrrq to enforce a reboot on kernel level. I've had similar issues with broken disk arrays which prevented proper shutdown and reboot. So you might at least not have to wait until your battery drains completely.

Assuming 'magic sysrq' is enabled in your kernel (kernel config CONFIG_MAGIC_SYSRQ) you can use Alt+SysRq+b to reboot the machine.

NOTE: This is forcing an immediate reboot without unmounting any HDD cleanly. So a file system check on next reboot might be required/recommended.

If you're running a graphical user interface like KDE or Gnome, then either switch to a console (using CTRL+Alt+F1) or try CTRL+Alt+SysRq+b from the GUI.

You might also have to check whether your kernel has magic sysrq enabled by typing cat /proc/sys/kernel/sysrq.

You can also initiate a sysrq-reboot on remote systems:

echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

This would lead to an immediate reboot if CONFIG_MAGIC_SYSRQ was compiled into the kernel.

More details on magic sqsrq can be found here.

NOTE: on the Samsung Series 9, the key labeled "Fn Lock" serves as SysRq, though it is not printed as such.

  • 1
    This might have worked, except that this laptop model does not have a SysRq key, believe it or not.
    – Zan Lynx
    Commented May 29, 2011 at 19:31
  • 1
    Damn... are you sure it's not "hidden" or not printed on the printscreen key? In any case the console variant should hard-reboot it too (assuming the machine is still responding on a terminal). All in all looks like a badly designed laptop to me (fixed battery, misbehaving power button, incomplete keyboard, maybe even glossy screen ;)).
    – SkyBeam
    Commented May 29, 2011 at 20:15
  • 3
    You can actually trigger sysrq by enabling Fn Lock and pressing Alt + Print + [key]. However, as the kernel is no longer alive, this doesn't do anything in this situation.
    – passy
    Commented Jun 4, 2011 at 15:05

I found a similar question on Yahoo Answers albeit with a different model.

One answer suggested holding down the power button for much longer. Failing that, it might be a sign that your motherboard might be on the way out.

If holding down the power button for longer still doesn't work and you have no access to battery, I think (like you said) your only option is to let the battery run down and switch itself off.

  • On some mainboard BIOS there is an option to enable shut down on long power button key press.
    – SkyBeam
    Commented May 29, 2011 at 10:49
  • 1
    Definitely not a motherboard issue because after rebooting (it did run down), it works again. Seems to be a pure software issue, except for the fact that the 4-second power cutoff is supposed to be hardware only, not software.
    – Zan Lynx
    Commented May 29, 2011 at 10:51
  • @Zan that's exactly what I thought... odd. Glad it's okay. Feel free to add that as an answer and mark it as 'accepted' in case anyone else runs into the same problem.
    – Kez
    Commented May 29, 2011 at 11:01

We let the battery run down completely. It simply would not power off. Attached the power cord and powered back on. It started up slowly, but completely and has been working fine ever since.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .