I think my question is a duplicate of this one, but the original question was never properly answered (the steps described are for Windows XP).

I am aware of the option to "Turn off Network Discovery" (under Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings); I set this option (for both Home/Work and Private) but it doesn't seem to stop the printers getting added, and has the side effect of preventing me from browsing the list of machines on the network (which I need).

I've tried the Windows XP registry option - but it doesn't seem to make any difference:


I find it annoying having the printer list cluttered with printers from all over the office which I am never going to use (especially since lots of them no longer physically exist, users just haven't deleted them from their machines). This must be a real problem for people in massive offices with large numbers of printers - but I can't seem to find a lot of people complaining about it - which makes me think I'm missing something obvious.

I don't really want to hack the firewall or turn off sharing completely, I still want to select and use network printers and file shares.

Any ideas?

  • Looking at the Microsoft help, there seems to be a third level of 'Network Discovery' On, Off and Custom. Anybody know how I can get custom? (secpol.msc doesn't seem to exist in Windows 7 Home Premium.) – Ben May 29 '11 at 11:43
  • Its a cop out, and does not really answer your question, you can remove the printers that are added, and they should not get readded. – soandos May 29 '11 at 11:47
  • Thanks, I'll try that. I had found they were automatically re-added, but that might be just because I switched from Wireless to Ethernet or something. – Ben May 29 '11 at 11:53
  • I've found out that Windows 7 Home does not have any kind of security snapin - its very annoying to pay for an upgrade and find a feature has been lost...anyway, I presume the 'custom' network discovery level is not accessible to me. – Ben May 29 '11 at 11:57
  • I can't believe it - wait 5 minutes, hit F5 - the damn things come back without even being connected to the network where they are shared – Ben May 29 '11 at 12:00

Try going to:

Control Panel (icon view)> Network and Sharing Center > Change advanced sharing settings (on left side of screen)

Under: Private > Network discovery

There is a box that says "Turn on automatic setup of network connected devices."

Uncheck that box and click "Save changes."

These instructions are for Windows 10, but they are probably similar for 7 and 8. I checked my Vista PC and I do not have this option. However, I never had printers auto install (software & EVERYTHING) with my Vista PC. I hope this helps.

  • Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. OP said in his question "I am aware of the option to "Turn off Network Discovery" " – DavidPostill Dec 27 '15 at 23:14
  • 3
    This answer is valid. The option to disable automatic setup of network devices is separate from the ability to disable network discovery. You want to leave network discovery on, but turn off automatic setup of network connected devices. – Darinth Jul 13 '17 at 12:53

See here: http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/0dd73a7b-f072-4182-abe6-3ce01f29b9f2

  • Thanks for that, it is helpful. Unfortunately I'm using Vista Home - I believe there is no group management snapin in Vista Home. What would be handy to know is where I can find out the underlying registry entries that correspond to the policy settings (if there is such a thing). Thanks. – Ben May 31 '11 at 11:52
  • Ahh, yep, with home you're outta luck. Need a PRO sku or higher. – pcunite May 31 '11 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.