I recently switched from Windows to Linux (Linux Mint specifically) on my IBM T61 laptop. Since making the switch, my touchpad has been nearly unusable. When I place one finger on the touchpad, without moving it, the cursor bobs around in a small area as if I am making a number of small movements. I think the cursor is moving around because the sensitivity is too high - just rotating the tip of my finger in place moves the cursor over about one-third of the screen. My trackpad does not suffer from the same problem.

I have lowered the sensitivity in the mouse settings to its minimum and I have tried to follow the advice from http://iruel430.blogspot.com/2010/06/lowering-mouse-sensitivity-in-ubuntu.html and also reduce laptop touch pad sensitivity in ubuntu. But, in both cases, my touchpad still has the same behavior.

Perhaps there is an xinput setting I am overlooking? Is there a better driver I can use for my T61?

  • It looks like adding an InputDevice section to my xorg.conf did the trick. After adding the following and restarting, the touchpad behaved much better. Section "InputDevice" Identifier "Synaptics Touchpad" Driver "synaptics" Option "SendCoreEvents" "true" Option "Device" "/dev/psaux" Option "Protocol" "auto-dev" Option "HorizEdgeScroll" "0" Option "SHMConfig" "on" EndSection – Michael Diamant May 30 '11 at 23:40

I usually hate necroposting, but I was having this same problem and it was driving me nuts. I found an answer that appears to work for me, on a Lenovo y500 running Ubuntu 13.10.

>xinput --set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Noise Cancellation" 20 20
  • 1
    This worked well for me, but I still had some noise at 20 20, so I increased it to 30 30 and that's working great. – Ian Dunn Apr 16 '15 at 5:10

I had this issue on many variants of linux. Currently I am on Elementary OS Loki. I had autoated the fix of this problem by creating following shell script at /etc/X11/Xsession.d/56touchpadfix

export `xinput list | grep -i touchpad | awk '{ print $6 }'`
xinput --set-prop "$id" "Synaptics Noise Cancellation" 20 20
xinput --set-prop "$id" "Synaptics Finger" 35 45 250
xinput --set-prop "$id" "Synaptics Scrolling Distance" 180 180

You need to tune values for your hardware. Mine work for Sony SVS series laptop.


I had a similar issue when I dual installed Win7 and OpenSUSE on my HP DV6-6047cl notebook. Actually, I had this problem with the touchpad in both OSes.

It's good you were able to resolve it. I'll post my resolution here in case it helps anyone else. I was able to resolve the issue in Linux by disabling the "tap to click" feature. I'm not sure where this is in the Ubuntu system, but if OpenSUSE had a setting I'm guessing Ubuntu has one too. That seemed to help a lot. It's pretty amazing that with all the problems people have had with the Synaptics touchpads for years now, it is still a problem on newer devices.

  • Thank you for posting your solution. When I hook my laptop to an external monitor, the cursor is still jumpy because the secondary monitor has a different resolution than the laptop. For some reason, Ubuntu does not adjust for this properly and this results in a jumpy cursor. Disabling 'tap to click' reduces this problem significantly. – Michael Diamant Jan 1 '12 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.