I have an SD Micro card that is not working any more.


What happened is I took it out of my old cellphone (it was working fine), and put it into my new cellphone (a Nokia E71). The Nokia complained that it was encrypted and prompted for a password. I have no idea why it would think that it was encrypted.

It wouldn't accept a blank password, so I tried 1234. That didn't work, so I swapped it back to the old phone, where it wasn't recognised anymore. Then I tried it in my laptop's card reader, and it doesn't work there either. I have a known good card that does work in the laptop.

I don't know whether I physically damaged the card when pulling/pushing it around between phones, or whether the Nokia did something to it..

I'd like to at least recover files from it if possible.

Troubleshooting details:

On my (Ubuntu linux) laptop, when I insert it into my card reader, /dev/sdc appears, but there's no /dev/sdc1 - no partition is found.

I tried to make an image of it thusly:

sudo dd if=/dev/sdc of=brokencard.img

But I get this error:

dd: opening `dev/sdc': No medium found

Then I tried this:

sudo fdisk /dev/sdc

And got this:

Unable to open /dev/sdc

I tried the photorec and testdisk utilites (from cgsecurity), but neither of them would find /dev/sdc.

I'm now out of ideas. What else can I try?


If you can't even access the device, you're pretty much SOL. My only suggestion is to try using different PC's / different card readers, you may get lucky. But most likely the card is dead. Probably not the Nokia's fault, just a coincidence, never heard of a specific device killing a SD card, they just sometimes fail. Lots more reliable than the old floppy discs, but not perfect.


If your only alternative is to throw it out, try this:

  • stick it in either device and try to format it. If this works, it won't likely be a "full" format, but only the high level structure. This may let you then at least find the device in linux. Once there, of course, you can try other tools.

  • for actual recovery, I've had good luck with magicrescue http://freshmeat.net/projects/magicrescue

  • I tried formatting it in the Nokia (none of the other devices I tried even detect its presence enough to format it) - but it just freezes the phone. I think it's a goner :( – Blorgbeard Aug 26 '09 at 3:45

You could try PhotoRec but you need to be able to mount the device first--it would be usable if you could get a dd image.

Edit: This is probably the little-used "S" part of the SD standard; most desktop operating systems don't support the security flags. You might be able to use another Nokia phone to completely wipe the card.


I've had good luck with dd_rescue. Of course if you can't access the device this would not be a viable option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.