I just resized a windows partition which involved shifting about 160GB to the left. After that it couldn't find the boot like normal so I ran the system repair tool like normal(I resize this partition a lot and each time I have to use the repair disk).

But, this time, when I rebooted into the recovered 7 partition, it displayed the windows logo like normal but then flashed up

autochk program not found -- skipping autocheck

After that being on the screen for about 8 seconds, there was a flash of a bluescreen with white text and it rebooted. I have tried running the repair disk multiple times, but it returns and fixes the same problem each time, and the same thing happens on boot each time. Is there anything I can do to fix this short of reinstalling Windows?

I have also ran two chkdsks from my vista partition with no errors reported and when viewing all the files on the drive everything seems to be in place.


I had this problem, and none of the fixboot/fixmbr/bootrec commands helped. Here's what did fix it:

It appears that the C: is mismapped for whatever reason. In my case, I guess it's because my migration software didn't find it.

Boot into the recovery console and launch regedit.

 For those not used to this language, that means: 
 - Boot from the Win7 disk 
 - At the "Install Windows" screen press SHIFT F10 to get a command window 
 - Type "regedit" (without the "") 
 - and press Enter

Select the HKLM hive and then use "load hive" to mount your c:\windows\system32\config\system hive (I name it 'offline'). You have to select HKLM so that Load Hive will be enabled, we're not actually going to load the offline hive into it.

 For those not used to this language, that means: 
 - Click to Select HKEY_LOCAL_MACHINE
 - Click File, Load Hive
 - Click the drop down arrow in "Look in"
 - Browse to C:\Windows\System32\config
 - Select SYSTEM and click Open
 - In Key Name type "offline"
 - OK

Now you're going to compare HKLM\System\MountedDevices (which is the recovery environment's device list) to HKLM\System\Offline\MountedDevices (which is the one for your failing windows install). In my case, I found that the recovery environment was correctly seeing C:, but the offline hive had the wrong disk signature for c:. (possibly because I deleted a recovery partition as part of the migration. So we need to put the right signature.

Look at the binary entry for DosDevices\C: in the recovery registry. Now go to the offline registry and fix your DosDevices\C: so it matches. In my case, I found it easiest to rename the bad DosDevices\C: to Z:, and then go through the \volume{guid} entries until I found the one that matches the working C:, and then rename that one to DosDevices\C:.

Unload the hive in the file menu, and then reboot. After I did that, I was able to boot.

 For those not used to this language, that means: 
 - Select "offline" in the left hand pane
 - Click File, Unload Hive
 - Yes
 - Close Registry Editor and the Command Window
 - Close the "Install Windows" screen
 - Yes
 - Remove the Win7 disk and boot into Win7.

Other internet searches implied that simply deleting all the offline DosDevices entries would force them to get correctly recreated, but that didn't work for me.

  • 1
    Fantastic, I can't believe it but this actually fixed it! As Gregor noted, "Load Hive" won't appear unless you have HKLM (HKeyLocalMachine) selected – Alex Apr 18 '13 at 14:11
  • I was able to revive a Windows 2008 R2 domain controller using the information listed above. When resizing a partition, we accidentally killed the 100MB recovery partition. First I had to do bcdboot c:\windows and bootsect /nt60 c: /mbr /force from the recovery console command line to make the drive bootable. Then I was able to use regedit to fix the C: mapping. In my case, DosDevices\C: was missing from the registry. – myron-semack Dec 11 '13 at 21:01
  • 1
    Protip for using Load Hive in regedit: You have to click one of the HKLM, HKCU, etc hives before it will work. It took me a while to figure out why this option was greyed out! You could also use REG LOAD from the command prompt before launching regedit. – myron-semack Dec 11 '13 at 21:02

The blue screen of death error usually find in Windows system and this is typically caused by software errors in device drivers.

The Blue screen treatment, you can refer to

1 restart

2 new hardware detection of new services

3 Trojan virus detected

4 checks BIOS and hardware compatibility

5 run “sfc / scannow” system to check whether documents have been replaced, and then use the installation disk to restore the system

you can try to boot your windows system in safe mode by pressing F8 repeatedly when you restart your computer.

  • It's not the bsod, I know that for a fact, and that isn't the main problem. I cant even boot into safemode because of this autocheck program, and for some reason I can't run sfc. – a sandwhich May 31 '11 at 11:38
  • @Ok sandwhich: can you please tell me when you are running the command of sfc what exact message you are getting? or not getting any message? – user82711 May 31 '11 at 12:19
  • I posted in the comments above the error message. – a sandwhich May 31 '11 at 17:36
  • I have another crap vista install, would I be able to run sfc from that? – a sandwhich May 31 '11 at 21:20

Reasons I can see for such a problem :

  • You may have reduced the system partition below its minimum size by using a 3rd-party partitioner
  • You may have changed the number of the partition by creating a new preceding partition
  • A copy error has occurred while moving the partition

In all cases, if you cannot undo the damage, and if the recovery options in the Windows 7 boot CD do not fix the problem, you may need to Do a Repair Install to Fix Windows 7. This will fix your currently installed Windows 7, while still preserving user accounts, data, programs, and system drivers (but ensure you have backups anyway).

  • I can't boot into windows, and that tutorial requires you to boot into windows. Is it possible to do a repair install without booting into windows? I think I would be able to fix it if I were to somehow force sfc to run, but for some reason I can't. – a sandwhich Jun 2 '11 at 17:33
  • You can also start it from the Windows 7 boot CD. – harrymc Jun 2 '11 at 17:59
  • Boot cd? The installation dvd? – a sandwhich Jun 2 '11 at 18:02
  • Yes, installation dvd. – harrymc Jun 2 '11 at 18:16
  • Whenever I boot into my install dvd, It goes straight into installation, how do I launch a repair install? – a sandwhich Jun 2 '11 at 18:28

Yostage, your Tutorial fixed the problem for me. I want to note that "load Hive" only works when you have selected HKLM. I had to try around a bit until I found out how it works.

And what do you know? Both DosDevices\C: entries were different. Fixed the wrong one, and Windows 7 booted without any problem.

I had Windows 7 on the 3rd partition on my primary HDD (500GB) of my Laptop. Then I deleted the 2nd partition, because I didn't needed it anymore, and added the free space to partition 1. This may have been the cause of the problem.


Very similar but not duplicate of this, so repeating my answer slightly.

It sounds to me like the 100Mb boot partition, has become deleted or part of the Windows boot loader has become faulty.

If you are not able to automatically recover using the startup recovery tool, you can choose Command Prompt as a repair option, then manually rebuild the boot sector.

Type the following:

bootrec /fixboot

bootrec /fixmbr

bootrec /rebuildbcd

This should, scan for errors, fix and rebuild the boot sector and repopulate the menu.

(If you want to read more about Bootrec, click here)

  • Wil, interesting read here, not directly related to this post but very interesting...blog.jitbit.com/2011/04/… – Moab May 30 '11 at 16:33
  • Well, I did that. It said all operations were completed successfully, but the last one said it found a total of 0 windows installs, so I am thinking that might be a problem. I rebooted and the same thing happened. Should I be navigate to the correct drive before doing this? – a sandwhich May 30 '11 at 16:40
  • @A Sandwhich, you won't like it, but if it couldn't find a Windows Install, you may be best of just reinstalling Windows. – William Hilsum May 30 '11 at 16:44
  • If I do reinstall, will there be a way to retain all of my current files? – a sandwhich May 30 '11 at 16:47
  • @Moab - Wow... Just wow... – William Hilsum May 30 '11 at 16:48

I just ended up doing a clean reinstall. Some of the files were left under a windows.old folder, can I just copy the programs into the new program files folder and expect them to work fine? Programs such as (cs4, iTunes, lightwave, maya, steam, crysis 2, other non steam games)


Inspired by Yostage's answer and reasoning, I found a another solution. Worked for me at least.

The goal is to make your system assign the new/editted partition as C: again.
A Win7 disk is still needed.

1) Boot from a Win7 disk
2) At the "Install Windows" screen press SHIFT F10 to get a command window 
3) Type "diskpart"          (without the "")

This loads the MS DiskPart command-line application. Now inside diskpart:

4) Type "list disk"         and find the disk # of the boot drive
5) Type "select disk #"     where # is the # noted before
6) Type "list part"         and find the part # of the boot partition (the one labelled "Primary")
7) Type "select part #"     where # is the # noted before
8) Type "assign letter=C"

Diskpart will then confirm that the letter has been successfully assigned to the partition.

You can shut down the system, eject the Win7 Disk, and boot from your drive once again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.