This is an old issue that I've tried to solve and apparently it's still valid, none of the updates so far have resolved it. It seems to be related to Gnome (gdm?) and Nvidia drivers, because for ex. On my desktop PC I just sidestepped the issue with an LXDE based install, which works fine, however I really do like Gnome for some reason, so it would be great to find the cause/solution to this.

Here are the details:

After a fresh install and installing all updates (latest kernel for 10.04 and latest packages), I cannot login on the graphical login screen. After entering the password the screen will turn black for a few seconds and then returns back to the login screen. But if I go to terminal with ctrl+alt+f1 I can login just fine, so my username/password is definitely OK.

On my laptop I use Ubuntu 10.04 95% of the time, and never ran into this issue, so I suspect it's hardware related. Maybe something graphics related (I have an Nvidia 9800GT on my desktop, but Ati card on laptop).

Any ideas on what I should look for or try? Which logs should I check to find out possible reasons/solutions to this problem.


It is immediately after a fresh install, on first login, so I don't have restricted drivers enabled. Only nvidia related packages installed are nvidia-173-modaliases, nvidia-96-modaliases, nvidia-common, nvidia-current-modaliases.

If i boot into recovery mode as root, and then run startx, I can get into GNOME.

Output of cat /var/log/gdm/:0-greeter.log

Window manager warning: Failed to read saved session file /var/lib/gdm/.config/metacity/sessions/103537dbc1e1d90e94130703607828717100000014670000.ms: Failed to open file '/var/lib/gdm/.config/metacity/sessions/103537dbc1e1d90e94130703607828717100000014670000.ms': No such file or directory
** (process:1477): DEBUG: Greeter session pid=1477 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-Jf8At5/database

(gnome-power-manager:1478): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.24.1/gobject/gsignal.c:2273: signal `proxy-status' is invalid for instance `0x203ed90'
gdm-simple-greeter[1477]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.1/gtk/gtkwidget.c:5636: widget not within a GtkWindow
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
  • Did you install the proprietary Nvidia drivers, or are you using the built-in Noveau drivers? If you log in on the text console and run startx, can you get into GNOME?
    – Patches
    May 31, 2011 at 17:40
  • @Patches: Updated my question with more info. Jun 1, 2011 at 20:08
  • @Beres: Have you tried doing a full update? (sudo apt-get dist-upgrade) If that doesn't help, please post the contents of /var/log/gdm/:0-greeter.log.
    – Patches
    Jun 1, 2011 at 23:41
  • @Patches: Added the log output. So far I did aptitude full-upgrade, not apt-get dist-upgrade however, as I would've liked to use latest LTS distribution. But I'll try to upgrade the distribution too, I'm curious if it fixes the issue. Jun 2, 2011 at 18:01
  • @Patches: Please ignore my previous comment about dist-upgrade, my mistake. I do have all the packages up to date at the moment though. Jun 2, 2011 at 18:08

2 Answers 2


This appears to be a known bug with the GNOME Display Manager (gdm) in Ubuntu 10.04 Lucid Lynx.

Comment #21 of that bug suggests disabling the Ubuntu logo splash screen will work around this issue. To do so temporarily, you may edit the kernel arguments from the GRUB menu and remove the splash option. To do so permanently, remove splash from the GRUB_CMDLINE_LINUX_DEFAULT environment variable line in /etc/default/grub, and run sudo update-grub to make the changes take effect.

If that fails, you could also switch to a different display manager for the time being, like lightdm or KDE's kdm (which you can install without necessarily installing the KDE Plasma Desktop environment). You won't get GNOME's login screen, but you will still be able to login to a GNOME desktop. To install either of these, just run sudo apt-get install lightdm or sudo apt-get install kdm and restart. To login to a GNOME session, just choose GNOME or Ubuntu Desktop from the Session menu of your chosen display manager. It should remember your selection for future logins.

  • My father's machine had this problem but it was from an upgrade from 8.04 - kdm solved the issue.
    – Broam
    Jun 6, 2011 at 17:55
  • Thanks a lot for your help. I didn't end up needing this however as the issue mysteriously disappeared after another reinstall and format of /home drive. Works fine even with restricted drivers enabled at the moment. On previous try I think I've missed formatting /home, however I did have other installs before that with reformatting, so that is not necessarily the obvious problem. Another difference is that I've set /home to be encrypted, but I'm not sure how that would "fix" this. If the issue suddenly reappears this workaround will certainly be the first thing I'll try. Jun 8, 2011 at 7:30
  • Apparently the login issue only "went away" temporarily (on first boot after reinstall), after that it started behaving the same again. The etc/default/grub change didn't seem to help, but the workaround of installing kdm and then choosing GNOME session was OK. Jun 13, 2011 at 9:00
  • @Beres: If you haven't already, you can add splash back to /etc/default/grub and rerun sudo update-grub to get your pretty boot screen back. Also, if you'd like, you can report your experience to that bug and subscribe to be notified when/if it is fixed.
    – Patches
    Jun 13, 2011 at 22:06

This is almost certainly an nvidia binary driver problem. Completely remove the binary nvidia driver (apt-get purge should do the trick; i forget the nvidia binary driver package - will a kind soul edit this answer?).

This should cause you to fall back to nouveau or vga. Nouveau will probably work but you will have some bugs and no 3D acceleration. (I had better luck w/ 10.10 and nouveau.)

VGA will certainly work but you'll be constrained to such a tiny screen size the only thing to do is install one of the other drivers.

  • It certainly seemed to be nvidia related, but I don't have the restricted drivers installed (fresh install, first login) so it looks like it's something else. Also removed all other nvidia related packages. Updated my question with more concrete info. Jun 2, 2011 at 18:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .