I use VirtualBox to run a Ubuntu x64 guest under a Vista x64 host with a 19" and 15" monitor.

I enable seamless mode in VirtualBox, but the windows don't actually move anywhere other than the desktop of the Ubuntu guest.

I'd also like fullscreen mode to display across both monitors.

How can I do this?

8 Answers 8


According to this forum post and looking through the VirtualBox release notes this is only available to Windows Guests. I know the latest 3 release introduced huge improvements on the 3D rendering side and with OpenGL. I would assume this would be available in the near future.

And according to the 4.0 release notes, the feature is available!

Guest Additions: support for multiple virtual screens in Linux and Solaris guests using X.Org server 1.3 and later
  • 1
    As of 4.0 Beta 2, this feature is now available to X.org clients running version 1.3+... if you are feeling adventurous.
    – Goyuix
    Dec 9, 2010 at 23:50
  • 2
    Now that 4.0.2 is out, this feature is in, right? No need to be adventurous? Feb 3, 2011 at 19:11
  • I just tried it and multiple monitors works fine for me with Ubuntu 10.10 -I didn't even know Virtual Box 4.x added support for Linux guests - I gave up on checking with every release.
    – jmohr
    Feb 3, 2011 at 20:33
  • @drhorrible Thanks for updating my answer, I forgot about this altogether and haven't used VirtualBox in about a year. Feb 3, 2011 at 20:36
  • No problem, I'm just coming back after learning this feature is present, very excited! This is my first step towards going to Linux as primary. Feb 3, 2011 at 20:49

My solution involves running Ubuntu in headless mode and connecting through the Remote Desktop Connection tool. The display is full screen (no toolbars or menus) and spans both of my monitors. Here's what I did:

  1. Double video memory to 16 MB in VirtualBox display settings for the machine. Also enable "Remote Display" server. For some reason I couldn't use the default port of 3389.
  2. Run the machine in headless mode like this:

    VBoxHeadless.exe --startvm "Ubuntu 10.4 64-bit"

  3. Connect to the machine using the Remote Desktop Connection tool that comes with Windows.

    mstsc /span /v:


The fullscreen display in both monitors can be easily done.
Luke Dubber managed it and it is explained here:
1 - Install VirtualBox (its free, Windows, Linux and Mac)
2 - Once you have created your virtual machine (VM) edit your settings.
3 - Go to Display section and increase the Monitor Count.
4 - Make sure to increase your Video Memory. If you don’t it won’t work (I should know, took me a bit to figure out that was my issue). I would go with the maximum 128MB if possible.
5 - Install your OS (you can do this before step 3).
6 - Make sure to install the VirtualBox guest additions.
7 - Then reboot and once you are back in you should be able to use more than one.
To read from original link Click here:
Or go to the home page of Luke Dubber

The seamless mode is something I'm battling with also and haven't seen an answer to yet.


Assuming you have the guest additions... You can get an approximate full screen across 2 monitors if you edit your xorg.conf file (I run FC11... I'm not sure if ubuntu uses xorg.conf?) and then just manually stretch the window to fill both. This definitely isnt ideal, but it does get you more visible desktop space.

I have two monitors in windows they run at 1440x900 and 1280x1024 respectively. The setup below allows a max screen size of 32000x32000.

You then just have to change the display and drag it out.

 Default xorg.conf for Xorg 1.5+ without PCI_TXT_IDS_PATH enabled.
# This file was created by VirtualBox Additions installer as it
# was unable to find any existing configuration file for X.

Section "Device"
        Identifier      "Configured Video Device"
        Driver          "vboxvideo"

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Generic Monitor"
    Device      "VirtualBox graphics card"
    DefaultDepth    24
    SubSection "Display"
      Depth 24
      Modes     "1440x900" "1280x1024" "2720x1024"

As of VirtualBox 3.2.4, multiple monitor support is still only available for Windows guest operating systems. See the "Guest multi-monitor support" item in the Known Limitations chapter of the VirtualBox manual.

For Windows guests, apparently you just have to adjust the monitor count in the display settings or run in seamless mode. This post contains more details.


Enable a second guest monitor and use Fullscreen mode.

With the guest shut down, in VBox Settings->Display, increase video memory and set the number of monitors to 2. Staart the guest. On the guest's VBox menu, check View -> Display 2 -> Enable.

Use the View menu and Display 1 and Display 2 to control which monitor each guest display appears on.

Also, I just discovered that Seamless mode only seems to be useful when I have more than one guest monitor. In that case, I can drag windows from the the guest onto the other monitor. With a Windows host, this does funny things to the desktop background and taskbar, but it works.


I have linux on host and guest (Debian & Debian). Virtualbox 7.0.8 with the Guest Additions.

Your VM has to be configured with 2 monitors, also the Host.

I got it working, but it is a bit tricky. Sometimes you have to try several times, but it works (at least with my config).

Get the two windows representing each monitor, maximized in each monitor. Set "Auto-resize Guest Display"

enter image description here

Set Input > Mouse Integration (without this, I got the screens working well, but the mouse was moving on both screens at the same time).

[Correct me if I am wrong] For "Mouse integration" to be there, the VM has to be started in 'Normal' mode (not Detached mode).

enter image description here

Now get it to Fullscreen.

You may notice that the screen on the right OR second screen is not visible, while the first one is full screen in its own monitor. Sometimes, it is there, but at the bottom, where only the Virtualbox menu for the VM is visible when you move the mouse to the bottom. In the menu, click on Maximize. Other times, the 2nd screen is there (because of the VirtualBox menu) but got Disabled and you have to Enable it again).

enter image description here

As mentioned above, you may have to play/cycle a few times, until it works.

Note: My 2 monitors have different sizes and it works well, as far as the resolution on the Host machine is properly setup.


I had a way to workaround it (see my other answer) but I just discovered a better one (more direct).

  1. Set the VM in full-screen mode

  2. One of the monitors is not full-screen [ this is the problem ]

  3. Hit Host-Key + Home (see image below) This will make the VM menu appear in the center of the screen.

  4. If the 2nd monitor is the one giving problems, go to

View > Virtual Screen 2 > Use Host Screen 2 (even if it already selected, like in the image below).

enter image description here

I know it doesn't make much sense, but it just works in one shot and without having to leave the VM.

Host-Key can be reconfigured in VirtualBox, so it depends of your settings.

Home key

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .