35

I just finished setting up a default Linux EC2 instance and would like to install PHPMyAdmin. I already have Apache and MySQL installed but cannot seem to install PHPMyAdmin. I tried using

sudo apt-get phpmyadmin but the command apt-get is not recognized.

I also tried sudo yum install phpmyadmin but that I get the message No package phpmyadmin available.

Any suggestions on what I am doing wrong?

11 Answers 11

47

I found an easy solution here.

Do the following:

  1. Navigate to the apache folder

    cd /var/www/html
    
  2. Ensure ownership of the folder (assuming signed in with ec2-user)

    sudo chown ec2-user .
    
  3. Download phpMyAdmin

    wget https://files.phpmyadmin.net/phpMyAdmin/4.5.0.2/phpMyAdmin-4.5.0.2-all-languages.tar.bz2
    
  4. Unzip

    tar -jxf phpMyAdmin-4.5.0.2-all-languages.tar.bz2 -C /var/www/html
    
  5. Rename the folder

    mv phpMyAdmin-4.5.0.2-all-languages phpmyadmin
    
  6. Remove the zip file

    rm -rf phpMyAdmin-4.5.0.2-all-languages.tar.bz2
    

That's the basics. You can find more info in the link provided above.

| improve this answer | |
36

I know the question has more than one year, but was the first thing that popped up on google with "phpmyadmin ec2". Here is a better way to do things.

Knowing that you have yum, the best way to act is to install it by yum.

The easy way is to activate it just to install the packages you want, like phpMyAdmin or MongoDB. Eg.

sudo yum --enablerepo=epel install phpmyadmin

and it should work.

EDIT (comment by @eric-brotto):

It also should be noted that this comes with the advantage of uninstalling via

(sudo) yum erase phpmyadmin

Eric Brotto Jun 8 at 16:22

Note, that this would install phpmyadmin in /usr/share/phpmyadmin. To make it available in your web root, you would have to symlink it thus:

sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin

There are two ways to use EPEL, one is above, the other is to activate it permanently, editing the file /etc/yum.repos.d/epel.repo and where it says enabled=0 we change it to enabled=1, now you can sudo yum install phpmyadmin.

Here you can see a package list for the EPEL repo, too.

| improve this answer | |
  • 4
    I don't think it gets any easier than this. The tl;dr? Just copy and pasted yum --enablerepo=epel install phpmyadmin – Tuanderful Oct 12 '12 at 7:43
  • 2
    There are many answers on the web stating how to use yum to install phpmyadmin. None of them worked for me. This one does. A million up votes be showered unto thy! – Eric Brotto Jun 8 '13 at 16:18
  • 3
    It also should be noted that this comes with the advantage of uninstalling via yum erase phpmyadmin. – Eric Brotto Jun 8 '13 at 16:22
  • 1
    Rats. It's all installed. I've created the symbolic link. I've restarted the server but all I get is: You don't have permission to access /phpmyadmin on this server. – Django Reinhardt Feb 4 '15 at 15:01
  • 1
    For me, it's /usr/share/phpMyAdmin instead of /usr/share/phpmyadmin. That's phpMyAdmin with capital M and A. – Pang Mar 20 '15 at 3:03
7

First add the repository, then install:

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
sudo rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.i386.rpm 
sudo yum install phpmyadmin 

This works fine on a standart 32bits amazon instance

| improve this answer | |
  • Also working well on 64bit amazon linux. This is may be better for some users then the "accepted" answer as it resolves the dependencies faster then doing a manual install. – Nir Levy Feb 8 '12 at 15:34
  • 3
    note that you'll need to supplement this install with "ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin" – Nir Levy Feb 8 '12 at 15:36
1

Note that if, after using any of the above methods to install phpMyAdmin, the phpMyAdmin page is empty in example.com/phpmyadmin, then you probably need to edit httpd.conf to allow overrides in the web directory, e.g.:

sudo nano /etc/httpd/conf/httpd.conf
  1. Find <Directory "/var/www/html">
  2. Replace AllowOverride none with AllowOverride all
  3. Save changes and exit
  4. Restart Apache server

    sudo service httpd restart
    
| improve this answer | |
1

I don't have permissions to comment, so as a separate answer.

1) Check what LINUX you have

rpm -q centos-release
lsb_release -a
uname -m

2) Check the correct rpm distribution release for you

http://pkgs.repoforge.org/rpmforge-release/

3) Add that distribution

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
sudo rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.i386.rpm 

4) Install the application

sudo yum install phpmyadmin 
ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin
vim /usr/share/phpmyadmin/config.inc.php

5) Create permissions to MySQL if necessary (replace pmapass with your own password!)

GRANT USAGE ON mysql.* TO 'pma'@'localhost' IDENTIFIED BY 'pmapass';
GRANT SELECT (
    Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv,
    Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv,
    File_priv, Grant_priv, References_priv, Index_priv, Alter_priv,
    Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv,
    Execute_priv, Repl_slave_priv, Repl_client_priv
) ON mysql.user TO 'pma'@'localhost';
GRANT SELECT ON mysql.db TO 'pma'@'localhost';
GRANT SELECT ON mysql.host TO 'pma'@'localhost';
GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv)
    ON mysql.tables_priv TO 'pma'@'localhost';
| improve this answer | |
0

The package is called phpMyAdmin. You may need to enable EPEL first.

| improve this answer | |
  • Can you provide more clarification? How do I go about enabling EPEL? – David May 31 '11 at 21:04
  • Did you try reading "How can I use these extra packages?"? – Ignacio Vazquez-Abrams May 31 '11 at 21:11
  • That looks way too difficult just to install phpMyAdmin. See my answer for a better solution. – David Jun 2 '11 at 15:07
0

As of 13th December 2012, this works fine on an EC2 server:

sudo apt-get install phpmyadmin

No other steps necessary, assuming you have PHP, MySQL and Apache all set up.

| improve this answer | |
  • 1
    How can I access it through web browser once installed ? – Happy Coder Jun 28 '14 at 7:21
  • apt-get is not available. – Django Reinhardt Feb 4 '15 at 14:43
0

The latest version of the micro server does not include EPEL rep. The following installs it:

sudo yum install -y epel-release

then you can run:

sudo yum --enablerepo=epel install phpmyadmin

| improve this answer | |
0

I know this is an old question but it came up in Google and the above answer didn't do it for my freshly installed EC2 Linux (June 2017). You don't need to do any of the sym linkage mentioned in other answers, the install makes an apache config file for the phpmyadmin installation automatically, you just need to remove the localhost security restriction, then restart httpd.

If you want a quick copy and paste to get it working in 2017:

sudo yum --enablerepo=epel install phpmyadmin

Edit the httpd config file which was created by the phpmyadmin yum installation:

sudo nano /etc/httpd/conf.d/phpMyAdmin.conf

Comment out this section near the top of the file, it is restricting access to localhost (and you're connecting over the internet not locally):

<Directory /usr/share/phpMyAdmin/>
#<IfModule mod_authz_core.c>
  #Apache 2.4
# <RequireAny>
#   Require ip 127.0.0.1
#   Require ip ::1
# </RequireAny>
#</IfModule>   
#  <IfModule !mod_authz_core.c>
    #Apache 2.2
#    Order Deny,Allow
#    Deny from All
#    Allow from 127.0.0.1
#    Allow from ::1
#  </IfModule>
</Directory>

Restart Apache to pickup the changes.

sudo service httpd restart

In your browser you can now access at /phpmyadmin

As a side point, in the config file you edit if you wanted to change the address you can access phpmyadmin at, at the top you will see Alias lines, set them as you desire.

Alias /phpMyAdmin /usr/share/phpMyAdmin
Alias /phpmyadmin /usr/share/phpMyAdmin

example:

Alias /pma /usr/share/phpMyAdmin
| improve this answer | |
  • /etc/httpd/conf.d/phpMyAdmin.conf is not there. System wide search couldn't find it – digout Aug 2 '18 at 16:09
0

If this is a basic Amazon Linux AMI install, then consider it similar to CentOS 6.x (no systemd). Amazon has its own repository, which does not have phpmyadmin in it.

Therefore you need to:

  • install epel repository
  • enable epel repository
  • install phpmyadmin
  • configure phpmyadmin

Here goes:

yum install epel-release

yum-config-manager --enable epel

yum install phpmyadmin

Edit the file /etc/httpd/conf.d/phpMyAdmin.conf and replace 127.0.0.1 with the ip address you are using.

nano /etc/httpd/conf.d/phpMyAdmin.conf

Restart the web server

service httpd restart

| improve this answer | |
-1
sudo apt-get install phpmyadmin

once you have installed it, you must make a symbolic link (like a redirect) using

sudo ln -s /usr/share/phpmyadmin /var/www

to open (change your IP) http://XXX.XXX.XXX.XXX/phpmyadmin

you MIGHT see an error missing mcrypt. i couldnt solve, but it didnt get in the way.

for logging in user is "root" and the password is the one that you created during the phpmyadmin install

adapted from this tutorial

| improve this answer | |
  • 2
    The question specifically says that apt-get is not available. – Nick F Jun 6 '13 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.