9

I've already followed the steps for reinstalling the TCP/IP protocol driver. The problem I am experiencing is probably pretty specific, but I am hoping there is a general solution to fix. It seems like I need to reinstall the entire networking subsystem. If I can't do that then I am probably reinstalling the whole operating system.

Here are my symptoms:

  1. VirtualBox cannot find any networking hardware - so I cannot setup a host adapter or bridged adapter. I uninstalled/reinstalled/repaired VirtualBox a few times, then realized it wasn't the problem.
  2. The network status icon in the system tray always shows disconnected (even though I am connected via wireless - and the internet works.)
    systray shows network disconnected
  3. The Network Connections listing in Control Panel is empty (the place where the adapters should be listed.)
    Network Connections is empty
  4. Connections on the Network and Sharing Center is blank. Connections on the Network and Sharing Center is blank
  5. Device manager lists my wireles networks adapter with the status "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"
  6. Updating the driver for my networks adapter says "The best driver software for your device is already installed." even if I uninstall the drivers first.
  7. See update on Netmon below.

I was having some networking issues with VirtualBox after updating to the new version. I noticed I had LogMeIn Hamachi installed, which included a virtual adapter. I wasn't using it, so I uninstalled it. Then reinstalled VirtualBox. At this point the networking seemed worse. It was in the process of debugging that when I discovered the other symptoms.

When I researched the problems with VirtualBox everything I read said that doing a repair would fix it. I did a repair, I even uninstalled it and reinstalled it. Still the same behavior.

There used to be a lot of adapters listed in the Network Connections screen, not just the wireless adapter. I am connected right now though, so the network works, but Windows 7 is reporting that it does not.

Vital stats:

  1. I am running Windows 7 Ultimate 64-Bit.
  2. There is no 3rd party wireless software.
  3. I didn't notice anything in the event log.

Update: Another symptom is my "Network Connections" (Netmon) service, which "manages the network connections folder" tends to hang (max out one core) and not restart when I tell it to. I'm guessing that is the most telling symptom there.

3

You want to use the "Change Adapter Settings" link then look at the properties of all of the physical adapters (connected and disconnected), you will also see the virtual adapters - don't change these unless you need to.

In each NIC you will see one or more line items for the virtual adapters. Enable or Disable as needed - for instance if you never use the wired NIC you can disable the virtual adapter for that device.

2
  • There-in lies my problem. I have no adapters listed in that window. This is probably the correct answer for a functioning system. Jul 18 '11 at 18:18
  • I noticed on the screen shot there is a reference to "Akamai NetSession Interface", that may be worth looking into. I am not familair with it but this web page has some interesting info: akamai.com/html/misc/akamai_client/…
    – jtreser
    Jul 19 '11 at 14:50
2

Unexplainable loss of network connectivity, usually via wired and wireless (wifi) networking Windows 7 for some reason needs to be system restored to the last working configuration, I've seen this happen on several pc's - Dell and Lenovo. Once customers roll back the network starts working again, and from that point on works without difficulty. No network stack resets or driver updates resolved this.

1
  • Why is it I always forget "last known good." Good tip. May 29 '13 at 20:10
1

I assume there is a 3rd party wireless app/service running to control the wireless? (Would explain how you can still connect) reinstalling that may reset things. Also, I couldn't tell if you'd just removed the logmein adapter, or the whole thing, but if it was the former, i'd reinstall/uninstall that, just in case.

1
  • Ah, thanks, I forgot to mention there is no 3rd party wireless control application. Also I uninstalled the LogMeIn software. I'll try reinstalling it I guess. Jun 1 '11 at 14:07
1

Jim,

Assuming you have completed this stage of checks, but still - Have you checked windows services? Is everything running, that are supposed to?

I doubt if 3rd party connection software can be blamed, as the device drivers should still be visible.

2
  • Are there specific windows services I should look for? I didn't see any that were obvious to me. Jun 1 '11 at 14:29
  • My "Network Connections" (Netmon) service, which "manages the network connections folder" tends to hang (max out one core) and not restart when I tell it to. Jun 2 '11 at 23:51
1

I ended up reinstalling the OS.

1
  • yeah after nobody reply to the question , reinstall is the solution :( sad but true , I remind the question How reset /reinstall the networking of windows 7 ? , when windows don't let you modify the network settings , firewall can't be enabled and or file sharing is not working.
    – Sérgio
    Jan 8 '16 at 16:23
0

I am (still) having similar issues, that seem to be related to the registry permissions in HKLM/SYSTEM/CurrentControlSet/ (e.g. Services/TCP and Control/Network). By resetting the permissions and giving access to Administrators, Network Configuration Operators, LOCAL SERVICE, NETWORK SERVICE, I was able to restore the basic functionality. (see this question, which also has not been solved)

Tweaking.com has a repair util, that does some of the stuff: http://www.tweaking.com/content/page/windows_repair_all_in_one.html

(I am normally happy if netsh int ip reset and ipconfig /renew works without any errors)

The problem is that because of the still inconsistent set of permissions, this lasts not to long.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.